it-swarm.com.ru

Как понизить версию инструментов командной строки MacOS

Я получил ошибку динамического компоновщика с символом __clock_gettime, поэтому я сделал то, что было сказано в этом посте Отсутствует символ при установке Ruby-2.3.0 на OS X 10.11.6 от RVM (т.е. xcode-select --install), и теперь я получаю Ошибки загрузчика, которые говорят о том, что библиотеки были созданы для более новой версии ОС, чем та, на которой я сейчас работаю, я не хочу обновлять свою ОС до более новой (Sierra) версии, хотя, есть ли способ, которым вы можете понизить инструменты командной строки до старая версия (10.11?)

6
Curious

Неясно, какую версию Xcode вы используете, хотя возможно иметь несколько версий установленных инструментов командной строки, которые можно выбрать в настройках Xcode.

enter image description here

4
l'L'l

Инструменты командной строки поставляются с Xcode. Если вы удаляете и понижаете версию Xcode, это должно сработать. После того, как вы удалите Xcode из ваших приложений, используйте ссылку "Предыдущие версии Xcode также можно скачать здесь" в https://developer.Apple.com/support/xcode/ . ПРЕДУПРЕЖДЕНИЕ СПОЙЛЕРА: Для этого вам необходимо/создать учетную запись Apple dev

2
bardukb