it-swarm.com.ru

Как установить PhpStorm в Ubuntu 14.04 LTS?

У меня есть JetBrains PhpStorm 7.1, и я хочу установить его в Ubuntu 14.04, поэтому я установил wine для совместимости с Windows и запускаю PhpStorm-7.1.exe, после чего он был успешно установлен (наверное). Но когда я запускаю установленное PhpStorm, я получаю сообщение об ошибке:

Не удалось создать JVM: код ошибки -1

Как я могу это исправить?

18
leonardeveloper

Инструкции здесь: https://web.archive.org/web/20161207101644/http://sysads.co.uk:80/2014/08/08/install-phpstorm-7-on-ubuntu-14 -04 /

Обратите внимание, что PhpStorm не является БЕСПЛАТНЫМ, это 30-дневная пробная версия!

Установить зависимости

Sudo apt-get purge openjdk*
Sudo add-apt-repository ppa:webupd8team/Java
Sudo apt-get update
Sudo apt-get install Oracle-Java8-installer Oracle-Java8-set-default

Установить PhpStorm

wget http://download-cf.jetbrains.com/webide/PhpStorm-2017.1.4.tar.gz
tar -xvf PhpStorm-2017.1.4.tar.gz
cd PhpStorm-171.4694.2/bin/
./phpstorm.sh
25
Nitish Dhar

JetBrains публикует весь свой портфель IDE в виде снимков, включая PHPStorm. Snaps работают на всех поддерживаемых версиях Ubuntu, включая 14.04. Некоторые из преимуществ оснастки JetBrains заключаются в том, что они всегда обновляются, автоматически обновляются и очень просты в установке.

Установите PHPStorm в Ubuntu 14.04

Sudo apt install snapd Sudo snap install phpstorm --classic

3
Martin Wimpress

Установить зависимости

Sudo apt-get purge openjdk*
Sudo add-apt-repository ppa:webupd8team/Java
Sudo apt-get update
Sudo apt-get install Oracle-Java7-installer Oracle-Java7-set-default

Установить PhpStorm

wget http://download-cf.jetbrains.com/webide/PhpStorm-7.1.3.tar.gz
tar -xvf PhpStorm-7.1.3.tar.gz
cd PhpStorm-133.982/bin
./phpstorm.sh
3
KAS

Для новых версий:

Sudo apt-get purge openjdk*
Sudo add-apt-repository ppa:webupd8team/Java
Sudo apt-get update
Sudo apt-get install Oracle-Java8-installer

wget http://download-cf.jetbrains.com/webide/PhpStorm-2016.2.tar.gz
tar -xvf PhpStorm-2016.2.tar.gz
cd PhpStorm-145.258.2/bin
./phpstorm.sh

примечание: если ссылка не работает, попробуйте более новую версию, текущая версия 2 по состоянию на июль 2016 года. Поэтому следующая версия будет PhpStorm-2016.3.tar.gz. И, конечно же, убедитесь, что вы выбрали правильный вариант cd PhpStorm-xxxx/bin

1
Claudiu Creanga