it-swarm.com.ru

Предпочитаемый плагин Ruby для Eclipse?

RDT (Ruby Development Tool) кажется предпочтительным плагином для добавления поддержки Ruby в Eclipse. Тем не менее, я вижу, что основной разработчик этого проекта присоединился к Aptana RadRails. Означает ли это, что проект больше не обновлен для Ruby в Eclipse?

Если так, какой плагин является предпочтительным и лучшим выбором в наши дни?

73
Lee Tang

Попробуйте Dynamic Languages ​​Toolkit для Ruby. Он доступен на панели обновлений программного обеспечения Eclipse.

91
Patrick O Connell

Хороший вопрос. Я использовал Aptana/radrails, и это определенно нужно избегать.

Он записывает базу данных в любой каталог, из которого вы запускаете Eclipse, и, как правило, захватывает Eclipse, изменяя множество полезных привязок клавиш.

Одна из самых раздражающих вещей в том, что Ctrl-1 перестает работать в файлах Java, и я использую горячую клавишу все время.

Я с нетерпением жду ответов людей на этот вопрос, потому что я хотел бы знать о хорошем.

18
Don Branson

Похоже, что сайт обновления находится здесь: http://download.Eclipse.org/technology/dltk/updates/

Я нашел это на www.Eclipse.org/dltk/install.php

12
Fitz

Я столкнулся с эта проблема после установки Aptana Studio плагин для Eclipse. Итак, я решил попробовать инструментарий динамических языков для Eclipse.

Если вы хотите удалить плагин aptana: Eclipse> Справка> Об Eclipse> Сведения об установке> вкладка "Установленное программное обеспечение"> Плагин Aptana> Удалить. Это должно сделать чистое удаление без разочарования.

Теперь давайте установим плагин DLTK.

Перейти по ссылке - http://marketplace.Eclipse.org/content/Ruby-dltk . Нажмите зеленую стрелку вниз. скопируйте ссылку из всплывающего окна.

enter image description here

Eclipse> help> установить новое программное обеспечение> работать с = скопированной ссылкой.

Теперь вы видите список плагинов. В этом списке разверните Языки программирования> установите флажок: Инструментарий динамических языков - Ruby Инструменты разработки> нажмите кнопку: далее> очевидные шаги.

После этого установите RubyInstaller для Windows по адресу http://rubyinstaller.org/ Найдите расположение Ruby.exe, созданного этой установкой. Это понадобится вам для установки интерпретатора Ruby при создании вашего первого проекта Eclipse Ruby.

После успешного создания проекта Ruby Eclipse спросит вас, хотите ли вы открыть перспективу Ruby. Скажи "ОК. Чтобы проверить, работает ли он, создайте проект Ruby, а затем создайте пустой сценарий Ruby внутри этого проекта. Затем выполните эту команду puts "hello Ruby" как сценарий Ruby. Наслаждайтесь игристым Ruby!

6
james

Я использовал Aptana/RadRails в прошлом, и я наслаждался этим. Я предлагаю попробовать. Доступен отдельный плагин Eclipse, который также неплохо поддерживает проекты, не относящиеся к Rails, если вы этого хотите.

Однако мой единственный опыт работы с "Затмением" был через Аптану, поэтому могут быть и другие соображения.

2
Samantha Branham

Dynamic Languages ​​Toolkit (DLTK) является предпочтительным. Пошаговая установка в Eclipse:

  1. Открытое Затмение
  2. Перейдите на Справка -> "Eclipse Marketplace ..."
  3. Введите DLTK в поле "Найти" и нажмите кнопку "Перейти"
  4. Нажмите кнопку Установить в разделе Ruby (DLTK)
  5. Следуйте инструкциям во всплывающем окне Eclipse.

Проверка правильности установки после успешной установки:

Перейдите на Окно -> Настройки, и вы увидите, что "Динамические языки" и "Рубин" зачислены на левой панели

2
Ripon Al Wasim