it-swarm.com.ru

Сбой сборки Numpy с невозможностью импортировать мульти-массив

Я использую доморощенный питон на Mavericks, пытаюсь собрать numpy 1.8. К сожалению, когда я пытаюсь установить numpy, я получаю следующую ошибку: https://Gist.github.com/ngoldbaum/8592039

Я могу собрать numpy 1.7.2 с помощью pip install numpy==1.7.2, но numpy 1.8 всегда не удается собрать с одной и той же трассировкой.

18
ngoldbaum

на Mac:

1.) удалите эти 2 папки вручную:

rm -rf /usr/local/lib/python2.7/site-packages/numpy/
rm -rf /usr/local/lib/python2.7/site-packages/numpy-1.10.4.dist-info/

обратите внимание: pip uninstall numpy у меня не работает, мне пришлось удалить numpy вручную.

2.) переустановите numpy: pip install numpy

33
Brian

Это было решено путем выполнения brew uninstall python, удаления содержимого /usr/local/lib/python2.7/site-packages, переустановки python, а затем перестройки numpy.

3
ngoldbaum

Я решил свою проблему следующим образом: Python.exe.\Lib\site-packages\easy_install.py

0
Jose Solis Jr.