it-swarm.com.ru

Ошибка при установке Подушки (модуль Python) в Linux

Я пытаюсь установить подушку (модуль Python) с помощью pip, но он выдает эту ошибку:

ValueError: jpeg is required unless explicitly disabled using --disable-jpeg, aborting

Итак, как говорит ошибка, я попытался:

pip install pillow --global-option="--disable-jpeg"

Но это не так с:

error: option --disable-jpeg not recognized

Есть намеки, как с этим бороться?

150
mchfrnc

Спасибо @mfitzp. В моем случае (CentOS) эти библиотеки не доступны в репозитории yum, но на самом деле решение было еще проще. Что я сделал:

Sudo yum install python-devel
Sudo yum install zlib-devel
Sudo yum install libjpeg-turbo-devel

И теперь установка подушки заканчивается успешно.

33
mchfrnc

Сообщается об ошибке для Pillow здесь , которая указывает, что libjpeg и zlib теперь обязательно с Pillow 3.0.0.

инструкции по установке для Pillow в Linux дают советы о том, как установить эти пакеты. Обратите внимание, что не все перечисленные ниже пакеты могут отсутствовать на вашем компьютере (комментарии показывают, что фактически отсутствует только libjpeg8-dev).

pip/PyPi (Подушка> 3.4.2)

последние выпуски Подушки доступны на PyPi как колеса - новый стандартный механизм упаковки для Python. Эти готовые пакеты включают все необходимые двоичные зависимости, позволяющие запускать Pillow, и их следует использовать, если вы хотите установить Pillow с использованием PyPi

Для использования колес необходимо иметь версию pip>=1.4. Если вы используете более раннюю версию (pip --version), обновите pip с помощью следующего:

pip install --upgrade pip 

После обновления pippip install по умолчанию будет использовать файлы колес для платформы, если они доступны. Используйте следующую команду, чтобы обновить Pillow до последней версии, доступной в PyPi:

pip install --upgrade pillow

Ubuntu 12.04 LTS или Raspian Wheezy 7.0

Sudo apt-get install libtiff4-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.5-dev tk8.5-dev python-tk

Ubuntu 14.04

Sudo apt-get install libtiff5-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

Ubuntu 18.04

Sudo apt install libjpeg8-dev zlib1g-dev

Fedora 20

Эквивалентом libjpeg8-dev в Fedora 20 является libjpeg-devel.

Sudo yum install libtiff-devel libjpeg-devel libzip-devel freetype-devel lcms2-devel libwebp-devel tcl-devel tk-devel

Mac OS X (через Homebrew)

В Mac OS X с Homebrew это можно исправить с помощью:

brew install libjpeg zlib

Вам также может понадобиться принудительно связать zlib с помощью следующего:

brew link zlib --force

Обновление от апреля 2019 года: В Мохаве вышеописанное не будет работать, и вам нужно выполнить следующее как взято из этого отчета об ошибке на подушке знак равно

Sudo installer -pkg /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg -target /

Обновление за июль 2016 года: Больше нет формулы для zlib, доступной в главном хранилище (Homebrew предложит вам установить lzlib, которая представляет собой другую библиотеку, и будет не решить эту проблему).

Там есть формула, доступная в dupes хранилище. Вы можете нажать на этот репозиторий и установить как обычно:

brew tap homebrew/dupes
brew install zlib

Или вы можете вместо этого установить zlib через xcode:

xcode-select --install

Благодаря Фениксу, Паносу Ангелопулу, Нельсонварела, Бенджаминзу и Калу в комментариях

После того, как они установлены, установка подушек должна работать нормально.

293
mfitzp

На Raspberry Pi II у меня была такая же проблема. Попробовав следующее, я решил проблему. Решение:

Sudo apt-get update
Sudo apt-get install libjpeg-dev
36
xjfengck

Самое быстрое решение - обновить пункт. Работал на меня:

pip install --upgrade pip
12
Aman Yadav

Это сработало для меня.

   `Sudo apt-get install libjpeg-dev`
12
Thomas John
brew install zlib

на OS X больше не работает и вместо этого предлагает установить lzlib. Установка, которая не помогает.

Вместо этого вы устанавливаете инструменты командной строки XCode, и это должно установить zlib

xcode-select --install
10
Kal

У меня был ValueError: zlib is required unless explicitly disabled using --disable-zlib, но обновление pip с 7.x до 8.y решило проблему.

Поэтому я постараюсь обновить инструменты прежде всего.

Это можно сделать с помощью:

pip install --upgrade pip
6
Brambor

Это помогло мне решить ошибку jpeg и zlib:

C:\Windows\system32>pip3 install pillow --global-option="build_e
xt" --global-option="--disable-zlib" --global-option="--disable-jpeg"
5
B-shan

Альтернатива, если вы не хотите устанавливать libjpeg:

CFLAGS="--disable-jpeg" pip install pillow

От https://pillow.readthedocs.io/en/3.0.0/installation.html#external-libraries

2
shangxiao

Пытаться

pip install pillow

Если это не работает, попробуйте очистить

cache by pip install --upgrade pip

Потом опять беги

pip install pillow
0
Tzvi Gregory Kaidanov