it-swarm.com.ru

Ошибка импорта: ни один модуль с именем numpy

У меня очень похожий вопрос к этот вопрос , но все еще на шаг позади. У меня установлена ​​только одна версия Python 3 в моей 64-битной системе Windows 7 (Извините).

Я установил numpy по этой ссылке - как предложено в вопросе. Установка прошла нормально, но когда я выполняю 

import numpy

Я получил следующую ошибку:

Ошибка импорта: нет модуля с именем numpy

Я знаю, что это, вероятно, супер основной вопрос, но я все еще учусь.

Спасибо

132
Seb

Добавлена ​​поддержка Python 3 в NumPy версии 1.5.0 , поэтому для начала вы должны загрузить/установить более новую версию NumPy.

40
unutbu

Вы можете просто использовать 

pip install numpy

Или для python3 используйте

pip3 install numpy
170
Andrei Madalin Butnaru

Я думаю, что что-то не так с установкой numpy . Вот мои шаги для решения этой проблемы.

  1. перейдите на этот веб-сайт, чтобы загрузить правильный пакет: http://sourceforge.net/projects/numpy/files/
  2. распаковать пакет
  3. перейти к документу 
  4. используйте эту команду для установки numpy: python setup.py install
14
Haimei

У меня также была эта проблема (Ошибка импорта: ни один модуль с именем numpy), но в моем случае это была проблема с моими переменными PATH в Mac OS X. Я ранее внес изменение в мой файл .bash_profile, который вызвал пути для моей установки Anaconda (и другие) не будут добавлены должным образом. 

Просто добавьте этот комментарий в список здесь на тот случай, если другие люди, подобные мне, зайдут на эту страницу с тем же сообщением об ошибке и столкнутся с той же проблемой, что и я.

9
Bill

Вы установили версию Numpy для Python 2.6 - так что вы можете использовать ее только с Python 2.6. Вы должны установить Numpy для Python 3.x, например, что: http://sourceforge.net/projects/numpy/files/NumPy/1.6.1/numpy-1.6.1-win32-superpack-python3.2.exe/download

Обзор различных версий см. Здесь: http://sourceforge.net/projects/numpy/files/NumPy/1.6.1/

7
naeg

У меня тоже была эта проблема после того, как я установил Numpy. Я решил это, просто закрыв интерпретатор Python и открыв его снова. Это может быть что-то еще, чтобы попробовать, если у кого-то еще есть эта проблема, возможно, это сэкономит несколько минут!

6
Chet

1) Установите numpy через командную строку (в windows) 2) перейдите в папку сценариев и введите команду ниже

C:\Python27\Scripts> pip install numpy

установка начинается, как показано ниже: Сбор numpy Загрузка numpy-1.13.3-2-cp27-none-win32.whl (6,7 МБ) 100% | ################################ | 6,7 МБ 112kB/s Установка собранных пакетов: numpy Успешно установленная numpy-1.13.3

6
harshitha yendapally

Я точно не знаю, почему я получаю ошибку, но pip3 uninstall numpy, а затем pip3 install numpy решили эту проблему для меня.

3
Clay H

Для установки NumPy через Anaconda (используйте команды ниже): 

  • конда установить -c Конда-Forge Numpy
  • конда установить -c Конда-Forge/метка/сломанный Numpy
3
Rashmi Nagpal

Я установил numpy в одной и той же среде с помощью pip и conda, и простого удаления и переустановки либо было недостаточно.

Я должен был переустановить оба.

Я не знаю, почему это случилось внезапно, но решение было

pip uninstall numpy

conda uninstall numpy

удаление из conda также удалило torch и torchvision.

затем

conda install pytorch-cpu torchvision-cpu -c pytorch

а также

pip install numpy

это решило проблему для меня.

3
Gulzar

Я тоже столкнулся с вышеуказанной проблемой с phyton 3 при настройке python для машинного обучения.

Я выполнил следующие шаги:

Установите python-2.7.13.msi

• установить PATH = C:\Python27

• установить PATH = C:\Python27\Scripts

Перейти к http://www.lfd.uci.edu/~gohlke/pythonlibs/#scipy

Скачано: - - numpy-1.13.1 + mkl-cp27-cp27m-win32.whl

          --scipy-0.18.0-cp27-cp27m-win32.whl 

Установка numpy: Pip install numpy-1.13.1 + mkl-cp27-cp27m-win32.whl

Установка scipy: pip install scipy-0.18.0-cp27-cp27m-win32.whl

Вы можете проверить правильность, используя ниже cmds: -

>>> import numpy
>>> import scipy
>>> import sklearn
>>> numpy.version.version
'1.13.1'
>>> scipy.version.version
'0.19.1'
>>>
2
Vikram S

Те, кто использует xonsh, делают xpip install numpy.

2
neckTwi

это проблема версии numpy, пожалуйста, посмотрите $ CAFFE_ROOT/python/demand.txt. Затем exec: Sudo apt-get install python-numpy> = x.x.x, эта проблема будет решена.

1
zhangyi
import numpy as np
ImportError: No module named numpy 

Я получил это, хотя я знал, что numpy был установлен, и безуспешно попробовал все советы выше. Для меня исправлением было удалить как np и напрямую обратиться к модулям. (python 3.4.8 на Centos) .

import numpy
DataTwo=numpy.stack((OutputListUnixTwo))...
1
zzapper

Столкнулся с той же проблемой

ImportError: No module named numpy

Таким образом, в нашем случае (мы используем PIP и python 2.7), решение было в виде команд SPLIT pip install: 

От 

RUN pip install numpy scipy pandas sklearn

К

RUN pip install numpy scipy
RUN pip install pandas sklearn

Решение найдено здесь: https://github.com/pandas-dev/pandas/issues/25193 , это связано с последним обновлением pandas до v0.24.0

1
Nigrimmist

После того, как я попробовал много предложений с разных сайтов и схожих вопросов, у меня получилось удалить все компоненты Python и переустановить только Anaconda (см. https://stackoverflow.com/a/38330088/1083292 ).

Предыдущая установка Python, которую я имел, была не только избыточной, но и доставляла мне неприятности.

0
erezmk