it-swarm.com.ru

Не удалось найти версию, которая удовлетворяет требованию numpy == 1.9.3

Попытка установить quandl и необходимость в pandas, поэтому я пытаюсь установить pip install pandas и ​​получить:

Не удалось найти версию, которая удовлетворяет требованию numpy == 1.9.3 (из версий: 1.10.4, 1.11.0, 1.11.1rc1, 1.11.1, 1.11.2rc1, 1.11.2, 1.11.3, 1.12.0b1 , 1.12.0rc1, 1.12.0rc2, 1.12.0, 1.12.1rc1, 1.12.1, 1.13.0rc1, 1.13.0rc2, 1.13.0, 1.13.1, 1.13.3, 1.14.0rc1, 1.14.0, 1.14 .1, 1.14.2) Не найдено подходящего распределения для numpy == 1.9.3.

Я использую python 3.4, win32

Я очень новичок в этом, спасибо за помощь

3
Jony

Просто используйте эту команду:

pip install pandas==0.19.0.

Старая версия, которая не будет плакать с этой ошибкой!

2
Nikhil Sharma

Текущая quandl более щедра в своих требованиях:

https://pypi.python.org/pypi/Quandl

Requires Distributions
pandas (>=0.14)
numpy (>=1.8)

Это githubsetup это то же самое: https://github.com/quandl/quandl-python/blob/master/setup.py

1
hpaulj

Я изменил ПОСЛЕДНУЮ ВЕРСИЮ на requirements.txt на pandas == 0.23.1 - в то время был последний выпущенный релиз - Вы можете зарегистрироваться pandas

1
Alex Montoya

Просто установите Python 3.5 или выше.

1
Ashish S

У меня была такая же проблема при установке панд из источника, ветка 0.22.x. Я следовал эти шаги и получил эту ошибку:

$ python -m pip install -e .
Obtaining file:///Users/mmorin/Software/pandas
  Could not find a version that satisfies the requirement numpy==1.9.3 (from versions: 1.11.3, 1.12.0rc2, 1.12.0, 1.12.1rc1, 1.12.1, 1.13.0rc1, 1.13.0rc2, 1.13.0, 1.13.1, 1.13.3, 1.14.0rc1, 1.14.0, 1.14.1, 1.14.2, 1.14.3)
No matching distribution found for numpy==1.9.3

Я обнаружил эту проблему на GitHub, где @djhoese предложил использовать версию 9.0.3 из pip вместо версии 10.0.1. Я добавил эту строку в ci/environment-dev.yaml:

 - pip==9.0.3

Я дал окружению новое имя для ясности, поэтому весь файл:

name: pandas-dev-pip9
channels:
  - defaults
  - conda-forge
dependencies:
  - Cython
  - NumPy
  - moto
  - pytest
  - python-dateutil
  - python=3
  - pytz
  - setuptools
  - sphinx
  - pip==9.0.3
0
mmorin

У меня была похожая проблема , и мне сказали, что Pandas больше не поддерживает Python 3.4, поэтому вам нужно будет установить более старую версию Pandas (и, возможно, более старую версию numpy) для работы с Python 3.4. 

Не очень приятно, я знаю, но это так.

0
nickdmax