it-swarm.com.ru

Модуль не обнаружил ошибку в Pycharm, но он установлен как пакет Anaconda

После этого я установил Anaconda 3 и pycharm CE. Я могу выбрать переводчика для среды conda. Но когда я пытаюсь использовать определенные пакеты, такие как matplotlib, выдается «Ошибка модуля не найдена». Когда я запускаю pip, он возвращает сообщение о том, что matplotlib доступен. 

pip install matplotlib
Requirement already satisfied: matplotlib in./anaconda3/lib/python3.6/site-packages

Ясно, что пакет есть, и по какой-то причине он не обнаруживается.

Заранее спасибо.

7
Ash

Нашел решение. Пошел в Pycharm -> Настройки -> Python Interpreter 

выбрал "существующий переводчик" и указал на ~/anaconda3/bin/python 

 enter image description here

Наконец, теперь все пакеты, установленные с Anaconda3, загружены. 

 enter image description here

Надеюсь, это кому-нибудь поможет. 

7
Ash

Перейдите в Pycharm -> Настройки -> Python InterpreterВыберите Использовать символ диспетчера пакетов Conda (зеленый кружок).

После обновления выберите символ «Установить (^ N)». Поиск установленного пакета.

0
LadyK