it-swarm.com.ru

как обновить спайдер на анаконде

У меня установлена ​​Anaconda (Python 2.7.11 | Custom Anaconda (64-разрядная версия) | (по умолчанию, 16 февраля 2016 г., 09:58:36) [64-разрядная версия MSC v.1500 (AMD64)] на win32), и я использую Spyder 2.3.8 

Я хотел бы обновить Spyder до последней версии, поэтому я прошел через команды:

conda update conda
conda update anaconda
conda update spyder

Все они работали без ошибок, но версия spyder не изменилась - это команда, которую я использую для запуска:

C:\Anaconda2\pythonw.exe C:\Anaconda2\cwp.py C:\Anaconda2 "C: /Anaconda2/pythonw.exe" "C: /Anaconda2/Scripts/spyder-script.py" --new-instance

Я что-то пропустил?

Спасибо

47
Diego

Чтобы расширить комментарий juanpa.arrivillaga :

Если вы хотите обновить Spyder в корневой среде, то conda update spyder Работает для меня. 

Если вы хотите обновить Spyder для созданной вами виртуальной среды (например, для другой версии Python), тогда conda update -n $ENV_NAME spyder, где $ENV_NAME - имя вашей среды.

57
jrinker

Я вижу, что вы использовали pip для обновления. Это настоятельно не рекомендуется (по крайней мере, в Spyder 3). Уведомления об обновлениях Spyder, которые я получаю, всегда включают следующее: 

«ВАЖНОЕ ПРИМЕЧАНИЕ. Похоже, что вы используете Spyder с Anaconda/Minconda. Пожалуйста, не используйте pip для его обновления, так как это, вероятно, нарушит вашу установку. Вместо этого, пожалуйста, подождите, пока будут доступны новые пакеты conda, и используйте conda для выполнения обновления. " 

11
Ed Roberts

Перейдите в Anaconda Naviagator, найдите spyder, нажмите «Настройки» в верхнем правом углу приложения spyder. Нажмите «Обновить» вкладка

5
theyk

Один из способов избежать ошибок при установке или обновлении пакетов - запустить Anaconda Prompt от имени администратора. Надеюсь, поможет!

1
ricalm

Используя pip напрямую:

ВНИМАНИЕ: Это нарушит вашу установку Anaconda, как описано сопровождающим Spyder в комментариях ниже; Вы можете попробовать это решение, только если решение, упомянутое выше, которое использует Conda, не работает

pip install --upgrade spyder

При запуске нового Spyder «nbconvert> = 4.0: None (NOK)» вы можете получить сообщение об ошибке, которое потребует от вас установки configparser для смолы:

конда удалить configparser

конда установить configparser

Теперь у вас должна быть свежая и актуальная установка Spyder.

0
Alexandre Willame