it-swarm.com.ru

Eclipse, PyDev "Не указан переводчик проекта"

Я установил PyDev в Eclipse Luna. После успешной установки PyDev, когда я хочу создать новый проект, я получаю ошибку: Не указан интерпретатор проекта

Как я могу это исправить? У переводчика нет выбора. 

Версия Eclipse Luna, Mac OSX Yosemite, Последняя версия PyDev (установлена ​​в соответствии с http://pydev.org/manual_101_install.html )

enter image description here

12
apadana

В моем случае это работало со следующими шагами

Предварительное условие: Python должен быть установлен

  1. Зайдите в Window -> Preferences -> PyDev -> Interpreters и нажмите «Python Interpreter».
  2. Затем нажмите на новую кнопку и добавьте исполняемый файл Python.

Пример для windows:

c:\python2.7\python.exe

пример для убунту:

/usr/bin/python
  1. Затем вы можете прикрепить изображение и нажать на готово.

Он должен работать.

34
ramesh bommakanti

На моем Mac 10.11.3, используя LiClipse 2.5.3, я решил это с помощью следующих шагов:

Откройте окно терминала и введите which python

В моем случае он ответил с /usr/bin/python

При вызове python он сообщил мне, что я использую версию 2.7.10.

Затем я позвонил LiClipse и пошел LiClipse -> Настройки -> PyDev -> Интерпретаторы -> Интерпретатор Python -> Новый

Для «Имени переводчика» я использовал «Python 2.7.10», хотя я знаю, что это просто символическая ссылка, и она может быть обновлена ​​в любое время . Для «Исполняемого файла интерпретатора» я ввел «/ usr/bin/python»

Тогда хорошо"

После этого сообщение об ошибке ушло.

 setting python interpreter location

2
Alexandre Santos

В моей системе Windows установленный путь к исполняемому файлу Python - C:\tools\python2\python.exe.

как упомянуто выше Перейдите в Окно Eclipse -> Настройки -> PyDev -> Интерпретаторы, нажмите «Интерпретатор Python» и укажите путь к исполняемому файлу Python.

0
Selvaji