it-swarm.com.ru

Пропустить composer PHP требование

Мы используем PHPCI и композитор. Сервер, на котором работает PHPCI, находится на PHP 5.3.

Для проекта мы добавили Facebook PHP SDK, используя composer. Требуется PHP 5.4. Composer запускается PHPCI и запускается. Но поскольку сервер CI только что получил PHP 5.3 composer, произошел сбой с сообщением об ошибке:

facebook/php-sdk-v4 4.0.9 requires php >=5.4.0 -> no matching package found.

Это, конечно же, провалило мою сборку в PHPCI.

Есть ли возможность пропустить это требование? Может быть, добавив опцию в composer.json? Или параметр для вызова composer.phar?

87
Armin

Я нашел вариант:

composer install --ignore-platform-reqs

Игнорировать требования платформы (php и ext-пакеты).


Редактировать: Вы можете пропустить проверки платформы с этим, но Composer будет получать пакеты на основе заданного PHP версия тогда. Поэтому, когда вам нужно composer для эмуляции версии PHP во время разрешения зависимостей, вы можете (и должны!) Использовать это в вашем composer.json:

{
    "config": {
       "platform": {
           "php": "5.6.6"
       }
    }
}

https://getcomposer.org/doc/06-config.md#platform

220
Armin