it-swarm.com.ru

Пакет libapache2-mod-auth-mysql недоступен

Я пытаюсь установить стек LAMP в Linux Mint 16 Mate x64, но всегда получаю сообщение об ошибке при запуске этой команды:

Sudo apt-get install mysql-server libapache2-mod-auth-mysql php5-mysql

Я использую исходные репозитории по умолчанию. Мне удалось установить Apache2, php5 и mysql, но всякий раз, когда я устанавливаю три пакета, он возвращает:

Пакет libapache2-mod-auth-mysql недоступен, но на него ссылается другой пакет.
Это может означать, что пакет отсутствует, устарел или доступен только из другого источника.

E: Пакет 'libapache2-mod-auth-mysql' не имеет кандидата на установку

Из-за этого я не могу использовать дружественную функцию URL.

16
moderadorkl25

Это подтвержденная ошибка. Смотрите это

3
user1526570

Согласно этот поток пакет libapache2-mod-auth-mysql больше не поддерживается и не нужен:

У меня создается впечатление, что многие люди оказались здесь, потому что хотят установить стек LAMP, поскольку в некоторых инструкциях где-то говорится, что этот пакет должен быть установлен для получения стека LAMP. Это неверно Этот пакет требуется только для проверки подлинности Apache по MySQL (в отличие от выполнения этого в конце веб-приложения, что встречается гораздо чаще). Мне кажется, что по Интернету ходят инструкции по обработке груза.

- Роби Басак

Я только что установил стек LAMP без этого пакета, и он работает нормально.

Sudo apt-get install php5-mysql phpmyadmin
16
Daniel Pelsmaeker

Я также только что установил пакет без libapache2-mod-auth-mysql. 

Кажется, работает просто отлично.

Sudo apt-get install mysql-server php5-mysql phpmyadmin
0
Nickel3ack