it-swarm.com.ru

Не удается установить laravel установщик через composer

Я пытаюсь установить laravel установщик с composer на моем компьютере с Ubuntu, но я получаю эту ошибку во время установки. `Ваши требования не могут быть разрешены для устанавливаемого набора пакетов.

  Problem 1
    - laravel/installer v1.4.1 requires ext-Zip * -> the requested PHP extension Zip is missing from your system.
    - laravel/installer v1.4.0 requires ext-Zip * -> the requested PHP extension Zip is missing from your system.
    - Installation request for laravel/installer ^1.4 -> satisfiable by laravel/installer[v1.4.0, v1.4.1].

  To enable extensions, verify that they are enabled in those .ini files:
    - /etc/php/7.0/cli/php.ini
    - /etc/php/7.0/cli/conf.d/10-opcache.ini
    - /etc/php/7.0/cli/conf.d/10-pdo.ini
    - /etc/php/7.0/cli/conf.d/20-calendar.ini
    - /etc/php/7.0/cli/conf.d/20-ctype.ini
    - /etc/php/7.0/cli/conf.d/20-exif.ini
    - /etc/php/7.0/cli/conf.d/20-fileinfo.ini
    - /etc/php/7.0/cli/conf.d/20-ftp.ini
    - /etc/php/7.0/cli/conf.d/20-gettext.ini
    - /etc/php/7.0/cli/conf.d/20-iconv.ini
    - /etc/php/7.0/cli/conf.d/20-json.ini
    - /etc/php/7.0/cli/conf.d/20-phar.ini
    - /etc/php/7.0/cli/conf.d/20-posix.ini
    - /etc/php/7.0/cli/conf.d/20-readline.ini
    - /etc/php/7.0/cli/conf.d/20-shmop.ini
    - /etc/php/7.0/cli/conf.d/20-sockets.ini
    - /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
    - /etc/php/7.0/cli/conf.d/20-sysvsem.ini
    - /etc/php/7.0/cli/conf.d/20-sysvshm.ini
    - /etc/php/7.0/cli/conf.d/20-tokenizer.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
`

Ошибка появляется, тогда я использую этот комментарий:

composer global require "laravel/installer"
75
Andreas Sauer

Там написано, что требуется расширение Zip

laravel/installer v1.4.0 требует ext-Zip ........

Установите версию, соответствующую установленной версии php:

# For php v7.0
Sudo apt-get install php7.0-Zip

# For php v7.1
Sudo apt-get install php7.1-Zip

# For php v7.2
Sudo apt-get install php7.2-Zip
147
Alex

Для PHP7.1 установите это

Sudo apt-get install php7.1-Zip
13
Muhammad F. Musad

На Centos 7 я использовал: 

yum install php-pecl-Zip

потому что любое другое решение не сработало для меня.

10
Evan

Для Ubuntu 16.04 я использовал эту команду для PHP7.2, и она сработала для меня.

Sudo apt-get install php7.2-Zip
3
Amit Khanna

Centos 7 с PHP7.2:

Sudo yum --enablerepo=remi-php72 install php-pecl-Zip
2
Amirul

Для PHP 7.2 в Ubuntu 18.04 LTS

Sudo apt-get install php7.2-Zip

Работает как шарм

1
Ian Samz

Для Mac с Macports, 

# port install php71-Zip
0
Toby

Sudo apt-get установить php-Zip

Это решение сработало для меня.

0
Elias Missaoui

Я использую WSL с версией Ubuntu 16.04 LTS с php 7.3 и laravel 5.7

Sudo apt-get install php7.3-Zip

Работа для меня

0
Fil

Расширение Zip отсутствует , Вы можете избежать этой ошибки, просто выполнив команду ниже, она будет принимать версию по умолчанию

Sudo apt-get install php-Zip

В случае, если вам нужна какая-то конкретная версия, вам нужно указать конкретную версию вашего php. Предположим, мне нужно установить X версию php-Zip, тогда команда будет.

Sudo apt-get install phpX-Zip  

Замените X на требуемую версию. В моем случае это X = 7.3

0
Ankur Tiwari

знать свою версию php

php -v 

для php 7.3.0

Sudo apt-get install php7.3-Zip
0
mohamed anwer