it-swarm.com.ru

Как установить конкретную версию пакета с помощью Composer?

Я пытаюсь установить конкретную версию пакета с помощью Composer. Я пробовал composer install и composer require, но они устанавливают последнюю версию пакета. Что делать, если я хочу более старую версию?

218
gdaras

composer require vendor/package:version

например:

composer require refinery29/test-util:0.10.2

380
alucic

Добавьте двойные кавычки, чтобы использовать оператор вставки в номере версии.

composer require middlewares/whoops "^0.4"
63
Nkoyan

просто используйте php composer.phar require

Например :

php composer.phar require doctrine/mongodb-odm-bundle 3.0

Также доступно с установкой.

https://getcomposer.org/doc/03-cli.md#requirehttps://getcomposer.org/doc/03-cli.md#install

16
Aize