it-swarm.com.ru

Как установить jQuery с помощью Composer?

Я смог установить репозитории, в которых нет файла composer.json, например:

    {
        "type": "package",
        "package": {
            "name": "yahoo/yui-compressor",
            "version": "2.0.4",
            "dist": {
                "url": "http://yui.zenfs.com/releases/yuicompressor/yuicompressor-2.4.7.Zip",
                "type": "Zip"
            }
        }
    },

Я взял часть "type": "Zip" из документации, но я не смог найти много других типов. Например, мне нужно установить jQuery, но я не знаю, что ввести в тип ("js" не работает).

    {
        "type": "package",
        "package": {
            "name": "jquery/jquery",
            "version": "1.7.2",
            "dist": {
                "url": "http://code.jquery.com/jquery-1.7.2.js",
                "type": "js"
            }
        }
    }

Есть идеи?

EDIT: я добавляю полное решение, чтобы помочь @CMCDragonkai:

    "require": {
        "vendorname/somefile": "1.2.3",
    },
    "repositories": [
        {
            "type": "package",
            "package": {
                "name": "vendorname/somefile",
                "version": "1.2.3",
                "dist": {
                    "url": "http://example.com/somefile.txt",
                    "type": "file"
                }
            }
        }
    ]
57
ChocoDeveloper

Это просто недостающая особенность. Вероятно, должен существовать новый тип dist, представляющий собой простой текстовый файл, который нужно загрузить и оставить как есть. Пожалуйста, отправьте запрос на функцию отслеживания проблем github: https://github.com/composer/composer/issues/

Правка : 

Функция на самом деле существует но не была задокументирована. 

"type": "file"
34
naderman

На самом деле есть более простой способ установить jQuery, просто наберите:

{
    "require": {
        "components/jquery": "1.9.*"
    }
}

Он использует Component Installer для Composer и по умолчанию все ресурсы компонента устанавливаются в components, но его можно настроить. ( см. документы ).

39
César

Как уже указывалось, в первой части решения определяются ваши собственные репозитории и опция определения репозитория "type: ": "file". Но следующая проблема - заставить композитора поместить JQuery туда, куда вы хотите. В нынешнем виде композитор, похоже, ограничен загрузкой источника зависимостей под vendor-dir (что раздражает, но, вероятно, связано с требованиями к автозагрузке). Общее исправление этого ограничения - написать плагин для композитора, который преодолеет его. Кажется, несколько плагинов, которые могут управлять этим. Самое простое и простое решение, которое я нашел, - это PHP Composer Asset Manager , которое предназначено для управления не PHP/Composer "активами". Тем не менее, он имеет по крайней мере одно ограничение в том, что изменения, которые делает плагин, не управляются/не обнаруживаются композитором. Все еще годен к употреблению.

Вот полный composer.json для установки JQuery с помощью этого плагина:

{
  "name": "foo/bar",
  "require":
  {
    "phpclasses/assets": "*",
     "jquery/jquery": "*"
  },
  "repositories": [
    {
     "type": "composer",
     "url": "http://www.phpclasses.org/"
    },
    {
      "type": "package",
      "package": {
        "name": "jquery/jquery",
        "version": "1.7.2",
        "type": "jquery",
        "dist": {
          "url": "http://code.jquery.com/jquery-1.7.2.js",
          "type": "file"
        }
      }
    }
  ],
  "extra": {
    "assets": {
      "actions": [
        {
          "type": "copy",
          "target": "webroot/js",
          "pattern": "\\.js$"
        }
      ],
      "packages": {
        "jquery/jquery": "*"
      }
    }
  }
}
2
spinkus

вы можете установить jquery с помощью npm, например, 

npm install jquery

https://www.npmjs.com/package/jquery

0

Используйте npm, yarn или WebPack вместо Composer, они лучше подходят для таких нужд.

0
snoob dogg