it-swarm.com.ru

Ошибка синтаксического анализа ESLint: неожиданный токен

С этим кодом:

import React from 'react';
import { Link } from 'react-router';
import { View, NavBar } from 'amazeui-touch';

import * as Pages from '../components';

const {  Home, ...Components } = Pages;

Я получаю эту ошибку eslint:

7:16  error  Parsing error: Unexpected token .. Why?

Вот мой конфиг eslint:

{
  "extends": "airbnb",
  "rules": {
    /* JSX */
    "react/prop-types": [1, {
      "ignore": ["className", "children", "location", "params", "location*"]
    }],
    "no-param-reassign": [0, {
      "props": false
    }],
    "prefer-rest-params": 1,
    "arrow-body-style": 0,
    "prefer-template": 0,
    "react/prefer-stateless-function": 1,
    "react/jsx-no-bind": [0, {
      "ignoreRefs": false,
      "allowArrowFunctions": false,
      "allowBind": true
    }],
  }
}

.... .... В чем проблема?

87
DongYao

Непредвиденные ошибки токенов при разборе ESLint возникают из-за несовместимости среды разработки и текущих возможностей синтаксического анализа ESLint с текущими изменениями в JavaScripts ES6 ~ 7.

Добавление свойства "parserOptions" к вашему .eslintrc больше не достаточно для определенных ситуаций, таких как использование

static contextTypes = { ... } /* react */

в классах ES6, поскольку ESLint в настоящее время не может разобрать его самостоятельно. Эта конкретная ситуация приведет к ошибке:

error Parsing error: Unexpected token =

Решение состоит в том, чтобы ESLint анализировал совместимый синтаксический анализатор. babel-eslint - это пакет, который недавно спас меня после прочтения этой страницы, и я решил добавить его в качестве альтернативного решения для всех, кто придет позже.

просто добавь:

"parser": "babel-eslint"

в ваш файл .eslintrc и запустите npm install babel-eslint --save-dev или yarn add -D babel-eslint.

Обратите внимание, что поскольку новый контекстный API , начиная с React ^16.3, имеет некоторые важные изменения, обратитесь к официальное руководство .

136
JaysQubeXon

ESLint 2.x экспериментально поддерживает синтаксис ObjectRestSpread, вы можете включить его, добавив следующее в свой .eslintrc: docs

"parserOptions": {
  "ecmaVersion": 6,
  "ecmaFeatures": {
    "experimentalObjectRestSpread": true
  }
},

ESLint 1.x изначально не поддерживает оператор распространения, одним из способов обойти это является использование анализатор babel-eslint . Последние инструкции по установке и использованию находятся в файле readme проекта.

45
Kevan Ahlquist

"parser": "babel-eslint" помог мне решить проблему

{
    "parser": "babel-eslint",
    "parserOptions": {
        "ecmaVersion": 6,
        "sourceType": "module",
        "ecmaFeatures": {
            "jsx": true,
            "modules": true,
            "experimentalObjectRestSpread": true
        }
    },
    "plugins": [
        "react"
    ],
    "extends": ["eslint:recommended", "plugin:react/recommended"],
    "rules": {
        "comma-dangle": 0,
        "react/jsx-uses-vars": 1,
        "react/display-name": 1,
        "no-unused-vars": "warn",
        "no-console": 1,
        "no-unexpected-multiline": "warn"
    },
    "settings": {
        "react": {
            "pragma": "React",
            "version": "15.6.1"
        }
    }
}

ссылка

26
user8202629

Сначала я решил эту проблему, установив babel-eslint с помощью npm.

npm install babel-eslint --save-dev

Во-вторых, добавьте эту конфигурацию в файл .eslintrc.

{
   "parser":"babel-eslint"
}
1
Joee