it-swarm.com.ru

Gulp: ошибка в консоли, assert.js: 90 сгенерировать новый assert.AssertionError

Я получаю такую ​​ошибку в консоли: $ Gulp

assert.js:90
  throw new assert.AssertionError({
  ^
AssertionError: Task function must be specified

at Gulp.set [as _setTask] (C:\Users\user\Projects\New project\node_modules\undertaker\lib\set-task.js:10:3)

at Gulp.task (C:\Users\user\Projects\New project\node_modules\undertaker\lib\task.js:13:8)

at Object.<anonymous> (C:\Users\user\Projects\New project\gulpfile.js:44:6)
at Module._compile (module.js:541:32)
at Object.Module._extensions..js (module.js:550:10)
at Module.load (module.js:458:32)
at tryModuleLoad (module.js:417:12)
at Function.Module._load (module.js:409:3)
at Module.require (module.js:468:17)
at require (internal/module.js:20:19)

Вот мой глоток:

var gulp = require('gulp');
var build = require('gulp-build');
var sass = require('gulp-sass');
var sourcemaps = require('gulp-sourcemaps');
var browser_sync = require('browser-sync');
var gulps = require("gulp-series");


//gulp-build
gulp.task('build', function() {
    gulp.src('scripts/*.js')
        .pipe(build({
            GA_ID: '123456'
        }))
        .pipe(gulp.dest('dist'))
});

//gulp-sass
gulp.task('sass', function() {
    return gulp.src('scss/**/*.scss')
        .pipe(sourcemaps.init())
        .pipe(sass({
            errLogToConsole: true,
            outputStyle: 'expanded'
        }).on('error', sass.logError))
        .pipe(sourcemaps.write('./maps'))
        .pipe(gulp.dest('css'));
});

//gulp-browser-sync
gulp.task('browser_sync', function() {
    var files = [
        '*.html',
        'css/*.css'
    ];
    browser_sync.init(files, {
        server: {
            baseDir: './'
        }
    });
});

//gulp-watch
gulp.task('watch', ['sass'], function() {
    gulp.watch('scss/**/*.scss', ['sass']);
});

//gulp-series
gulps.registerTasks({
    "test1": (function(done) {
        setTimeout(function() {
            console.log("test1 is done");
            done();
        }, 1000);
    }),
    "test2": (function() {
        console.log("test2 is done");
    })
});

gulps.registerSeries("default", ["test1", "test2"]);

// gulp.task('default', ['watch', 'browser_sync'], function() {});

Я просто новичок, ты хоть представляешь, что я сделал не так?

14
Lebiediev

Я думаю, что вы используете gulp 4 с синтаксисом gulp 3.
Так что либо установите gulp 3, и ваш gulpfile должен быть действительным и готовым к работе, либо перенесите его в gulp 4. Здесь хорошая статья об этом. 

Журнал изменений глотка 

35
DAXaholic

глоток 4 серии (... задания) 

gulp.task('one', function(done) {
// do stuff
done();
});

gulp.task('two', function(done) {
// do stuff
done();
});

gulp.task('default', gulp.series('one', 'two', function(done) {
// do more stuff
done();
}));

см. https://github.com/gulpjs/gulp/blob/4.0/docs/API.md

8
Dan Alboteanu

gulp автоматически устанавливает версию 4.0.0

измените версию глотка, выполнив команду ниже

 npm install [email protected] --save

Это решит вашу проблему.

3
Basavaraj Hadimani

Я решил проблему с помощью команды ниже

npm install --save-dev [email protected]

Это решит вашу проблему (я решил проблему в окне 7 и окне 10)

1
Suresh Suthar

Только что перешел на ту же ошибку, ответ DAXaholic правильно, ваш gulpfile.js's [email protected]*, но вы установили gulp 4. Просто установите правильную версию:

npm i -D [email protected]*
0
giovannipds