it-swarm.com.ru

Загрузите и установите JavaFX для Eclipse

Я опытный (Java, Eclipse & Maven) разработчик, и до сих пор использовал несколько фреймворков. Каждый раз, когда я пытаюсь начать с чего-то нового, создается впечатление, что для его загрузки и установки существует около миллиарда конфигураций.

Я посмотрел здесь для получения инструкций и всех ближайших страниц, но они кажутся устаревшими, путь к плагину Eclipse недействителен, и когда я устанавливаю последнюю версию, я не нашел сайт (2.0.2) , он говорит, что у меня установлена ​​более новая версия.

Кроме того, настройка Maven в большинстве прочитанных мной постов кажется неясной.

Я использую:

  • Windows 7
  • Eclipse x64 Indigo
  • JDK x64 1.6.0.24
  • Maven 3.0.3 

И я не помню, чтобы установить JavaFX.

Что я пропустил? Где я могу прочитать о настройке, чтобы начать работать с этим фреймворком?

10
TacB0sS

JavaFX устанавливается, если вы устанавливаете последнюю версию JDK 7 от Oracle (в комплекте).

Вы можете найти плагин Eclipse здесь: 

http://efxclipse.org/

Если вас интересуют сборки Maven: я недавно выпустил начальную версию Drombler FX, модульный RCP для JavaFX, основанный на OSGi и Maven (сначала POM):

http://puces-blog.blogspot.ch/2012/12/drombler-fx-building-modular-javafx.html

http://wiki.drombler.org/GettingStarted

14
Puce

Я попробовал efxclipse, но мне этого было недостаточно. Я также пытался указать путь к javfx-файлу javafx к efxclipse 

Window-> Prefferences-> javafx -> "Путь к javafx jar, который является Jfxrt.jar"

, Но у меня ничего не получалось, я не знаю, что пошло не так. 

Затем я просто добавляю файл jfxrt.jar в мою библиотеку, и все работает нормально: - 

 1. Right click your JRE System Library
 2. Build Path
 3. Configure Build Path
 4. Add External Jars
 5. "The path to jfxrt.jar"

Вы можете скачать файл jfxrt.jar по ссылке this .

Или же

Если вы уже скачали последнюю версию Oracle Java JDK, вы найдете по этому пути 

Extracted_Oracle_jdk_folder/JRE/Библиотека/внутр/jfxrt.jar

Вот и все должно работать нормально.

0
chandan sr

Попробуйте e (fx) clipse на http://efxclipse.org/ . Я - разработчик NetBeans, но слышал много хороших вещей об этом плагине от моего Eclipse, используя друзей.

0
Lakatos Gyula