it-swarm.com.ru

Уничтожить метод в bean-компоненте с именем org.springframework.boot.autoconfigure.internalCachingMetadataReaderFactory 'вызвал исключение

Я пытался решить это «исключение метода разрушения» с помощью онлайн-советов, но безуспешно. Вот сообщение об ошибке:

2017-10-16 15: 58: 13.234 ОШИБКА 12276 --- [main] o.s.b.f.s.DefaultListableBeanFactory: метод Destroy для bean-компонента с именем org.springframework.boot.autoconfigure.internalCachingMetadataReaderFactory 'вызвал исключение

А вот мои зависимости POM.xml:

<dependencies>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-actuator</artifactId>
    </dependency>
    <dependency>
        <groupId>org.springframework.cloud</groupId>
        <artifactId>spring-cloud-starter-aws</artifactId>
    </dependency>
    <dependency>
        <groupId>org.springframework.cloud</groupId>
        <artifactId>spring-cloud-starter-aws-jdbc</artifactId>
    </dependency>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-web</artifactId>
    </dependency>
    <dependency>
        <groupId>org.projectlombok</groupId>
        <artifactId>lombok</artifactId>
        <version>1.16.6</version>
        <scope>provided</scope>
    </dependency>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-data-jpa</artifactId>
    </dependency>
</dependencies>

Из Интернета кажется, что проблема заключается в зависимости spring-boot-starter-data-jpa. Я пробовал старые версии зависимостей и чистил mvn, но ни одна из них не работает.

Обновление

После регенерирования пом из весеннего инициализра я все-таки получил такую ​​же ошибку. Вот мои зависимости pom.xml:

    <dependencies>
<!--need this aws dependency for some packages-->
        <dependency>
            <groupId>org.springframework.cloud</groupId>
            <artifactId>spring-cloud-starter-aws</artifactId>
        </dependency>
<!--need this aws dependency for some packages-->
        <dependency>
            <groupId>org.springframework.cloud</groupId>
            <artifactId>spring-cloud-starter-aws-jdbc</artifactId>
        </dependency>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-web</artifactId>
        </dependency>
        <dependency>
            <groupId>org.projectlombok</groupId>
            <artifactId>lombok</artifactId>
            <version>1.16.6</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-data-jpa</artifactId>
        </dependency>
    </dependencies>

Какие-либо предложения?

3
Gene Xu

Здесь так много повторяющихся банок ..

Я бы пошел сюда чтобы создать весенний проект с необходимыми зависимостями.

0
surya

у меня была та же проблема с исключением 

:Destroy method on bean with name 'org.springframework.boot.autoconfigure.internalCachingMetadataReaderFactory' threw an exception
Java.lang.IllegalStateException: ApplicationEventMulticaster not initialized

и ошибка была в моем объявлении синтаксиса весеннего профиля 

@Profile({"production, dev"})

правильный путь:

@Profile({"production","dev"}) 
0
Jacob