it-swarm.com.ru

Ошибка при установке Maven Integration для Eclipse

Я пытаюсь установить интеграцию Maven для Eclipse (Galileo) через меню Install New Software nad, используя ссылку sonatype 

http://m2Eclipse.sonatype.org/sites/m2e

И получаю следующую ошибку: 

Не удается завершить установку, так как не удалось найти один или несколько обязательных элементов.
Устанавливаемое программное обеспечение: интеграция Maven для Eclipse (обязательно) 0.12.0.20101115-1102 (org.maven.ide.Eclipse.feature.feature.group 0.12.0.20101115-1102)
Отсутствует требование: интеграция Maven для Eclipse (обязательно) 0.12.0.20101115-1102 
(org.maven.ide.Eclipse.feature.feature.group 0.12.0.20101115-1102) требует 'org.Eclipse.emf.ecore.edit 0.0.0', но не может быть найден

Пытался искать пропавший комплект. Но безуспешно. :(

Любая помощь?

21
Pale Blue Dot

В диспетчере установки установите флажок «Связаться со всеми сайтами обновлений ...» и повторите попытку. Поскольку EMF поступает с сайта обновления, отличного от M2Eclipse, M2Eclipse не может быть установлен без возможности проверять все сайты обновлений на наличие необходимых компонентов.


Обновление!

Начиная с Eclipse 3.7 (Indigo), m2e теперь размещается на Eclipse.org. Чтобы установить его, вам просто нужно использовать сайт обновлений Eclipse по умолчанию:

51
Andrew Eisenberg

Вы используете Eclipse CDT? Если это так, вы должны убедиться, что у вас также установлены Java Development Tools. Предполагая, что вы используете Helios, используйте http://download.Eclipse.org/releases/helios/ в качестве сайта обновления и установите инструменты JDT из списка функций в разделе «Языки программирования». У меня была та же проблема, и это решило ее для меня.

7
deuberger

Начиная с Eclipse 3.7 (Indigo), m2e теперь размещается на Eclipse.org. Чтобы установить его, вам просто нужно использовать сайт обновлений Eclipse по умолчанию:

http://download.Eclipse.org/releases/kepler
http://download.Eclipse.org/releases/juno
http://download.Eclipse.org/releases/Indigo
etc.

Следовательно, для получения Maven в Eclipse Indigo, пожалуйста, обратитесь к ответу, выделенному желтым цветом вместе со скриншотом по ссылке ниже

Ошибка установки Eclipse Indigo на торговой площадке Maven Integration

5
Kishor

У меня та же проблема (кстати, по умолчанию "связаться со всеми сайтами обновлений"). Я нашел этот отчет об ошибках в Eclipse bugzilla, который указывает на то, что у нас есть проблема в самом плагине. 

https://bugs.Eclipse.org/bugs/show_bug.cgi?id=330896

Обходной путь для меня состоит в том, чтобы вернуться к более старым версиям m2Eclipse/m2Eclipse extras/subversive интеграция. Я использовал следующие URL:

3
jan groth

большинство Eclipse не поддерживает Maven 3,5 Iven 1,8. чтобы установить maven, вы должны перейти в halp - установить новое программное обеспечениеName:M2Eclipselocation: http://download.Eclipse.org/technology/m2e/releases/1.4

для гелиоса: http://download.Eclipse.org/technology/m2e/releases/1.3

1

Еще один способ установки подключаемого модуля Maven для Eclipse:

  • Открытое Затмение
  • Перейдите в Справка -> Торговая площадка Eclipse
  • Поиск по Maven
  • Нажмите кнопку «Установить» в разделе «Интеграция Maven для Eclipse»
  • Следуйте инструкциям шаг за шагом
  • После успешной установки выполните следующие действия в Eclipse:
    • Перейти к окну -> Настройки
    • Обратите внимание, Maven зачислен на левой панели
    • Нажмите на существующий проект
    • Выберите «Настроить» -> «Преобразовать в Maven».
0
Prabagar g

Убедитесь, что вы установили флажок, чтобы связаться со всеми сайтами обновлений во время установки, чтобы найти запрашиваемое программное обеспечение, прежде чем переходить к следующей установке Maven Integration для Eclipse и m2e-slf4j через logback logging (Необязательно).

я столкнулся с той же проблемой, прямо сейчас она решает, выполняя вышеуказанное .... Надеюсь, это поможет.

0
Garun Kumar Mishra

Чтобы установить новый m2e (1.4) на helios, мне пришлось удалить все maven элементы в Eclipse, а затем я мог установить m2e из http://download.Eclipse.org/technology/m2e/releases " ,.

Действия по удалению существующих элементов maven (из org.maven.ide. *):

  1. Нажмите в справке в Eclipse
  2. Установить новое программное обеспечение ...
  3. Нажмите на то, что уже установлено
  4. Выбрать все элементы из org.maven.ide. * (Даже если это обязательно)
  5. удалить их все
0
Reda