it-swarm.com.ru

Ошибка при попытке установить плагин

Я пытаюсь установить плагин в Eclipse Luna. Я установил Papyrus и пытаюсь установить конструктор SWT, но до завершения загрузки/установки я получаю сообщение об ошибке:

An error occurred during the
org.Eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
session context was:(profile=epp.package.standard,
phase=org.Eclipse.equinox.internal.p2.engine.phases.CheckTrust,
operand=, action=). Error reading signed content. error in opening Zip
file

После этой ошибки я не могу ничего установить, и менеджер установки больше не работает и показывает мне одну и ту же ошибку все время только одним способом: удалить текущий каталог Eclipse и извлечь его снова.

На этот раз я устанавливаю Papyrus, SWT дизайнер и некоторые другие, но я получаю ошибку между установкой другого плагина снова. Это неправильно, если я получаю ошибку при установке какого-либо из плагинов, переустанавливающих Eclipse и другой плагин снова.

Это ошибка или проблема?

55
user3855547

Хорошо, наконец, я нашел решение для решения этой проблемы, я не знаю, почему Eclipse показывает мне эту ошибку, и я не знаю, является ли это лучшим решением, но в любом случае я решаю свою проблему с удалением файла artifacts.xml в Корневой каталог Eclipse После удаления этого файла попробуйте снова установить этот плагин, но на этот раз через несколько секунд все сделано и работает отлично

ОБНОВЛЕНИЕ: Если вы получаете эту ошибку снова, просто перейдите в корневой каталог Eclipse, найдите «artifacts.xml» и удалите все файлы в результате;)

130
user3855547
  1. Удалите artifacts.xml из папки.

  2. Храните его копию в другом месте (предпочтительно на внешних устройствах, таких как pendrive или жесткие диски и т.д.).

  3. Перезапустите Eclipse. 

  4. Установите программный плагин, который вы хотите установить (он снова запросит разрешение).

  5. После установки вставьте файл artifacts.xml обратно в папку Eclipse.

  6. Перезапустите Eclipse и установите местоположение SDK.

  7. Код до смерти !!! ;п

20
Akshay

Запустите Eclipse от имени администратора, затем попробуйте установить плагин снова через help-> Install New Software. это сработало для меня

7
The Prince

Я установил E4 RCP Patch (bugzillas 445122) (Установить новое программное обеспечение -> Eclipse 4.4.1 Патчи для ошибки 445122), и это мне помогло.

2
Taras B

Я столкнулся с этой проблемой при обновлении внутреннего программного обеспечения Eclipse. Я обнаружил, что файл jar org.Eclipse.epp.mpc.help.ui_1.5.2.v20161004-1655.jar (найден в подробностях ошибки) в каталоге плагинов Eclipse был поврежден (7-Zip не смог проверить его содержимое) , Я заново загрузил и вручную заменил этот файл на один, загруженный с их сайта , и тогда я смог установить программное обеспечение без проблем. Надеюсь это поможет :)

(Если это был другой файл JAR для вас, вы можете нажать «показать содержимое каталога» на на этой странице и скачать тот, который вам нужен.)

1
Nathan Meyer

Недавно у меня была эта проблема, и я сделал несколько обходных путей, чтобы все исправить, 

Перетащите с официальной страницы, обычно Eclipse перезапускается после загрузки, и всплывающее окно попросит нас выбрать соединители svn из списка. но этого не случилось со мной.

  1. Установите плагин SVN. (путем перетаскивания или установки нового программного обеспечения или любого другого)

  2. После этого перейдите window->preferences->Team->svn

  3. выберите вкладку Connector и нажмите кнопку Get connectors, после чего появится подсказка, выберите любую connector, чтобы сделать это (я использую NativeHL 1.8).

0
Aravindh Gopi

Я решил эту проблему, отредактировав artifacts.xml.

  1. Закрыть Затмение.
  2. Отредактируйте artifacts.xml.
  3. Найдите и удалите предыдущие записи, относящиеся к плагину, который вы пытаетесь установить
  4. Сохраните artifacts.xml.

После этого вы сможете нормально запустить Eclipse и установить свой плагин.

0
Kent

Я попробовал многие решения, в том числе одно, которое гласит удаление artifacts.xml и попробуйте установить с открытием программного обеспечения с помощью Запуск от имени администратора также попытался установить с помощью параметра справки "Установить новое программное обеспечение" ничего из этого не сработало для меня.

Затем я обновился до последней версии JDK, и он работал отлично. Надеюсь, это поможет вам.

Спасибо . Виджай П.

0
Vijay P.