it-swarm.com.ru

IOS 11 GoogleMaps сбой на устройстве (iphone 5s)

Xcode 8.3.2 Iphone 5s ios 11 GoogleMaps 2.4

Я получаю ошибку и сбой в viewContoller

@IBOutlet weak var mapView: GMSMapView! 
override func viewDidLoad() { }

Журналы: 

CoreData: annotation:  Failed to load optimized model at path '/var/containers/Bundle/Application/2D2D05FB-A524-4594-B222-69B58E038E9A/Medico.app/GoogleMaps.bundle/GMSCacheStorage.momd/Storage.omo'
CoreData: annotation:  Failed to load optimized model at path '/var/containers/Bundle/Application/2D2D05FB-A524-4594-B222-69B58E038E9A/Medico.app/GoogleMaps.bundle/GMSCacheStorage.momd/Storage.omo'
CoreData: annotation:  Failed to load optimized model at path '/var/containers/Bundle/Application/2D2D05FB-A524-4594-B222-69B58E038E9A/Medico.app/GoogleMaps.bundle/GMSCacheStorage.momd/Storage.omo'
2017-09-21 16:02:08.805064+0300 Medico[2552:187180] [Common] _BSMachError: port 1187f; (os/kern) invalid capability (0x14) "Unable to insert COPY_SEND"

Это происходит только в IOS 11

12

https://stackoverflow.com/a/46391213/4831936

понизьте версию до 2.2 вы все равно увидите предупреждения, но не вылетите

1
DaNLtR

Это происходит потому, что вы только обновляете свой SDK. Ваш репо не обновлен.

Итак, первый шаг - обновить ваши модули, выполнив следующую команду:

обновление репо

После этого запустите:

обновление стручка

Как только это будет сделано, установите стручки снова. Убедитесь, что ваша версия GoogleMap должна быть 2.5.0. Он должен работать!!

0
User511

Обновите свой Xcode и Google Maps SDK. Это сработало для меня.

0
Hamid Baraghani

Я столкнулся с той же проблемой раньше, чем через несколько дней, на самом деле эта проблема связана с xcode и/или debuger.

Обходной путь для этой проблемы как ниже:

  • Из меню в xcode, перейдите в Product> Scheme> Edit Scheme.
  • Выберите вкладку «Выполнить», а затем выберите вкладку «Параметры».
  • Измените «Захват кадров GPU» с «Автоматически включено» или «OpenGL ES» на «Металл» или «Отключено».

Это оно!!

0
Ganpat

Обновите Google Maps SDK 2.5.0 и скомпилируйте с помощью Xcode 9. Это решит проблему.

https://developers.google.com/places/ios-api/releases

Проверьте 2.5.0 примечания к выпуску.

0
Desert Rose

Не нужно обновлять Xcode. Просто обновите Google SDK. Была такая же проблема. Это помогло мне.

0
Максуд Даудов