it-swarm.com.ru

Плагины, установленные на Eclipse, не видны

Когда я устанавливаю плагин в Eclipse, все идет хорошо. Но после перезапуска новый плагин не виден. Я пробовал это с разными плагинами, но у них все та же проблема. Единственное место, где я могу их увидеть - это когда я смотрю «Что уже установлено?».

В чем может быть проблема?

31
Derk

Эта проблема и ее решение описаны в статье DZone и в блоге nWire .
Все сводится к этим двум вариантам:

11
Zsolt Török
Sudo Eclipse -clean;  

Help --> Install software --> Переустановите плагины и программное обеспечение;

Объяснение:
Eclipse установлен, и Большинство программ также устанавливаются изначально с правами суперпользователя. 

Как правило, «Владение» скрытыми установочными папками принадлежит «Sudo» или пользователю Root. Поэтому изменения и установки в эти скрытые папки не возьмут. 

4
Alivallo

Вы пытались запустить Eclipse с аргументом -clean ? Вам нужно делать это только один раз, а не каждый раз, когда вы запускаете Eclipse, вам рекомендуется делать это после установки плагина.

Если это не помогает, проверьте, есть ли у вас права на запись в подкаталоги функций и плагинов. Процесс установки плагина требует права записи, но я никогда не видел, чтобы установка плагина была успешной без таковой; Тем не менее, стоит проверить.

3
Vineet Reynolds

Однажды у меня возникла проблема, когда я запускал Eclipse со старой jre - она ​​работала, но плагины, которые требовали jre6, не загружались. У вас есть недавняя jre на вашем пути и как ваш Java_home?

1
Adam Butler

Вы можете находиться в произвольной проекции, в которой команды плагина не установлены, чтобы быть видимыми (следовательно, нет меню, нет представления, ...). Смотрите этот вопрос больше о перспективах .

alt text альтернативный текст http://www.javalobby.org/images/postings/rj/Eclipse%5Fperspective/1.gif

Можете ли вы увидеть свои плагины в каталогах <Eclipse>/plugins и <Eclipse>/features?
Можете ли вы проверить вид «Журнал ошибок» и посмотреть, есть ли какие-либо сообщения об ошибках?
Можете ли вы увидеть, ссылаются ли Preferences на ваши плагины?

Вы также можете попробовать перезапустить Eclipse с аргументом командной строки -clean

1
VonC

У меня была похожая проблема, и в моем случае Eclipse начинал использовать более старую версию Java. Плагин Oozie требует версии Java 1.8. Выяснение Eclipse с использованием версии 1.8 Java исправило это для меня.

0
Prithviraj Dongrekar