it-swarm.com.ru

Установите gcc на Ubuntu 12.04 LTS

Когда я пытаюсь установить gcc на Ubuntu 12.04 LTS Server с помощью apt-get install gcc, я получаю следующую ошибку:

The following packages have unmet dependencies:
 gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) but it is not going to be installed
       Depends: gcc-4.6 (>= 4.6.1-1) but it is not going to be installed
       Recommends: libc6-dev but it is not going to be installed or
                   libc-dev

Когда я углубляюсь глубже (то есть пытаюсь apt-get install gcc-4.6), я получаю:

 gcc-4.6 : Depends: gcc-4.6-base (= 4.6.1-9ubuntu3) but 4.6.3-1ubuntu5 is to be installed
           Depends: cpp-4.6 (= 4.6.1-9ubuntu3) but it is not going to be installed
           Depends: libgomp1 (>= 4.6.1-9ubuntu3) but it is not going to be installed
           Depends: libquadmath0 (>= 4.6.1-9ubuntu3) but it is not going to be installed
           Recommends: libc6-dev (>= 2.13-0ubuntu6) but it is not going to be installed

Поэтому, когда я пытаюсь установить gcc-4.6=4.6.1-9ubuntu3, я получаю список из 366 пакетов для удаления (включая, например, apt). Что сумасшествие.

Это по сути установка Vanilla Ubuntu 12.04 LTS Server (т.е. я установил nginx, python-flup, python-yaml, rsync, python-pkg-resources, lsof, fontconfig, iptables, ufw, scons и grc).

Для меня очень удивительно, что я не могу установить gcc, поэтому я несколько озадачен тем, почему попытка установить gcc не удалась. Казалось бы, единственное очевидное исправление - удаление 366 пакетов, многие из которых являются центральными для работы Ubuntu.

Что-то не складывается, и я был бы очень благодарен за помощь.

EDIT Выше, конечно, с последними пакетами, использовав apt-get update; apt-get upgrade перед попыткой выше. Извините, я должен был упомянуть это.

53
Brian M. Hunt

Существует метапакет с именем build-essential, который должен установить компилятор и набор связанных/необходимых пакетов:

Sudo apt-get install build-essential

Предложение сначала выполнить Sudo apt-get update звучит правильно, это обновит списки пакетов, и все версии должны хорошо совпадать.

Это, однако, если вы не изменили свой файл /etc/apt/sources.list вручную. Если это так, то, возможно, некоторые из внесенных вами изменений или добавленных вами репозиториев содержат конфликтующие пакеты, которые вызывают проблемы, которые вы видите. Если это так, пожалуйста, посмотрите на файл и исправьте проблемные записи. Конечно, если вам нужна помощь, вы можете опубликовать свой файл sources.list (или любые фрагменты в /etc/apt/sources.list.d), и, возможно, кто-то может помочь вам исправить их.

86
roadmr

Постарайся идти глубже:

Sudo apt-get update
Sudo apt-get install gcc-4.6-base cpp-4.6 libgomp1 libquadmath0 libc6-dev
4
David M. Sousa

Сначала напишите команду:

Sudo apt-get update.

Тогда попробуйте:

Sudo apt-get install gcc

Я сделал это, и это сработало! Вы также должны попробовать это.

Если это не работает, то:

Sudo apt-get install build-essential

Тогда попробуйте. Надеюсь, это сработает!

1
Master Programmer