it-swarm.com.ru

После обновления - ошибка: не удалось найти: com.google.Android.gms: play-services: 5.2.8

Ошибка синхронизации проекта Gradle.

После обновления Android SDK я получил эту ошибку:

Ошибка: не удалось найти: com.google.Android.gms: play-services: 5.2.8

  • Я проверил, что местоположение SDK, которое обновляется, используется студией Android
  • У меня установлен Google Repository и Android Support Repository тоже все на 2 дату.
  • Также у меня есть локальная переменная Android_HOME, указывающая на SDK, который я на самом деле использую
19
LinkOut

попробуйте использовать com.google.Android.gms: play-services: 5.2.08 вместо 5.2.8.

вы также можете найти правильный номер версии в вашем каталоге услуг:

../Android-студия/sdk/extras/google/m2repository/com/google/Android/gms/play-services /

39
user3792866

Проверьте ваши дополнительные пакеты sdk, вам нужно установить:

  • Сервисы Google Play
  • Google Repository

Для меня было то, что у меня не было установлен второй, а затем "---: 5+" работал как описано здесь:

https://developers.google.com/mobile-ads-sdk/docs/admob/Android/quick-start

31
Caipivara

Предлагая использовать Open File> Project Structure, нажмите «add (+)», В поиске «play-service», чтобы выбрать текущую доступную версию . Что-то вроде этого изображения: http://i.stack.imgur.com/9Pv7j.jpg

0
Wesely

Теперь вы можете использовать

compile 'com.google.Android.gms:play-services:6.1.11'
0
friederbluemle

Я использую 

скомпилируйте 'com.google.Android.gms: play-services: 6.1. +'

Хотя это и предупреждает против этого. Если после обновления все пойдет не так, я вернусь к текущей версии.

0
Patrick Splinter

У меня такая же проблема. Я решил использовать:

compile 'com.google.Android.gms:play-services:7.0.0'
0
André Luiz Reis