it-swarm.com.ru

Ошибка плагина: обязательный плагин "Поддержка Android" отключен

У меня есть ошибка плагина в моем logcat

   10:08:28 PM Plugin Error
        Problems found loading plugins:
        Plugin "Google Analytics Uploader" was not loaded: required plugin "Android Support" is disabled.
        Plugin "SDK Updater" was not loaded: required plugin "Android Support" is disabled.
        Plugin "Android NDK Support" was not loaded: required plugin "Android Support" is disabled.
        Plugin "Google App Indexing" was not loaded: required plugin "Android Support" is disabled.
        Plugin "Google Cloud Tools For Android Studio" was not loaded: required plugin "Android Support" is disabled.
        Plugin "Google Cloud Testing" was not loaded: required plugin "Android Support" is disabled.
        Plugin "Google Services" was not loaded: required plugin "Android Support" is disabled.
        Disable not loaded plugins
        Enable Android Support
        Open plugin manager
 10:08:32 PM Error Loading Project: Cannot load 3 facets Details...

Это произошло после того, как я оставил свой ноутбук спать, и когда я открыл Android-студию, эта ошибка выскочила. Теперь я не могу запустить свой проект.

68
En Xin

Короче: 

  • WindowsLinux): перейдите в Файл -> Настройки -> Плагины -> Включить Поддержка Android

  • Mac: Android Studio -> Настройки -> Плагины -> Включить Поддержка Android

 enter image description here

Если вы посмотрите на ошибку, вы также найдете решение: 

3- Disable not loaded plugins
2- Enable Android Support
1- Open plugin manager
114
Milad Faridnia

Я столкнулся с той же ошибкой. Вот как я это исправил, хотя бы временно (пока профессионалы не покажут лучший способ это исправить). 

(On a Mac) Go to Android Studio -> Preferences -> Plugins. 

Вы заметите, что «Поддержка Android» Плагин снят. Снимите флажок с "Google Cloud Testing" , а затем проверьте "Поддержка Android" плагин. Нажмите кнопку «Применить» и нажмитеOK. IDE попросит вас перезагрузить , чтобы изменения вступили в силу. Нажмите OK, и когда IDE перезапустится, ваш код должен работать нормально.

62
Chhanda Bhattacharyya

Перейдите на Settings->Plugins->IDE Settings и просто отключите и снова включите необходимые плагины.

23
Jéwôm'

перейдите как файл потока -> настройки -> плагины . затем снимите флажок с красными параметрами . примените настройки Вы получите сообщение об ошибке без проблем . перепроверьте непроверенные параметры . нажмите ок .it попросит перезапустить Android studio, нажмите кнопку ОК, и это решит проблему и снова заработает.

14
Makvin

У меня возникла та же проблема, и я не смог включить плагин поддержки Android. Затем я отключаю плагины Google Cloud и плагины Firebase, а затем включаю плагин поддержки Android. После перезапуска AS я смог снова включить плагины Google Cloud и Firebase.

9
RSchmitt

Решение https://stackoverflow.com/a/40055520/1587329 также работает в Linux:

Файл -> Настройки -> Плагины -> Включить поддержку Android

screenshot settings plugins

Или просто нажмите Reset в правом верхнем углу.

8
serv-inc
  • Откройте файл c:\users\username.AndroidStudio2.3\config\disabled_plugins.txt 
  • удалить строку "org.jetbrains.Android"
  • перезапустите Android Studio
7
Florian Karbon

Я тоже сталкивался с этой проблемой. Если вы снимите флажок, то включите любой плагин для зависимостей (красный цвет), тогда IDE предложит диалоговое окно, чтобы включить «Поддержка Android», принять его и перезапустить IDE, проблема будет решена.

6
Pavan Kunchapu

если вы устанавливаете на ПК, на котором установлен язык по умолчанию, отличный от английского (в моем случае это был хинди), Android Studio не запустится. поэтому сначала измените язык вашей системы на английский. я сталкивался с этой проблемой два раза.

0
M9J_cfALt

Проблема со мной заключалась в том, что я импортировал настройки Android-студии с другого компьютера с другим именем пользователя. поэтому местоположение SDK было установлено в c:/users/mmstq/appdata/local/Android/android-sdk Но, к счастью, мои предыдущие настройки были заархивированы .. Куда SDK располагался как c:/users/matlo/AppData/Local/Android/Android-SDK

0
Matt