it-swarm.com.ru

Обновление конфликта версий до play-services 9.4.0 Android studio 2.2

Я получаю сообщение об ошибке 

 Error:Execution failed for task ':app:processDebugGoogleServices'.
    > Please fix the version conflict either by updating the version of the google-services plugin (information about the latest version is available at https://bintray.com/Android/android-tools/com.google.gms.google-services/) or updating the version of com.google.Android.gms to 9.0.0.

Я попытался просмотреть https://bintray.com/Android/android-tools/com.google.gms.google-services/ и com.google.gms: google-services: 3.0.0, похоже, является самый последний. Это мой проект Gradle

dependencies {
            classpath 'com.Android.tools.build:gradle:2.1.2'
            classpath 'com.google.gms:google-services:3.0.0'
            // NOTE: Do not place your application dependencies here; they belong
            // in the individual module build.gradle files
        }

И вот так выглядит мое приложение Gradle

buildscript {
        repositories {
            maven { url 'https://maven.fabric.io/public' }
        }

        dependencies {
            classpath 'io.fabric.tools:gradle:1.+'
        }
    }
    apply plugin: 'com.Android.application'
    apply plugin: 'io.fabric'
    apply plugin: 'com.google.gms.google-services'

    repositories {
        maven { url 'https://maven.fabric.io/public' }
    }


    Android {
        compileSdkVersion 24
        buildToolsVersion "24.0.1"
        useLibrary 'org.Apache.http.legacy'

        defaultConfig {
            applicationId "com.myapp.preburn"
            minSdkVersion 10
            targetSdkVersion 24
            versionCode 14
            versionName "2.0.1"
            renderscriptTargetApi 22
            renderscriptSupportModeEnabled true
        }
        buildTypes {
            release {
                lintOptions {
                    disable 'MissingTranslation'
                }
                minifyEnabled false
                proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
            }
        }
    }

    Android {
        packagingOptions {
            exclude 'META-INF/DEPENDENCIES'
            exclude 'META-INF/NOTICE'
            exclude 'META-INF/LICENSE'
        }
    }

    repositories {
        mavenCentral()
        jcenter()
    }

    dependencies {
        compile fileTree(dir: 'libs', include: ['*.jar'])
        compile fileTree(dir: 'libs', include: 'Parse-*.jar')
        compile 'com.parse.bolts:bolts-Android:1.2.0'
        compile 'com.Android.support:appcompat-v7:24.1.1'
        compile 'com.mcxiaoke.volley:library:1.0.9'
        compile 'com.google.Android.gms:play-services-gcm:9.4.0'
        compile 'com.google.Android.gms:play-services-location:9.4.0'
        compile 'com.google.Android.gms:play-services-maps:9.4.0'
        compile 'com.google.Android.gms:play-services-ads:9.4.0'
        compile 'com.google.Android.gms:play-services-plus:9.4.0'
        compile 'com.google.Android.gms:play-services-analytics:9.4.0'
        compile 'me.leolin:ShortcutBadger:[email protected]'
        compile 'com.squareup.picasso:picasso:2.5.2'
        compile files('libs/jsoup-1.7.3.jar')
        compile('com.crashlytics.sdk.Android:crashlytics:[email protected]') {
            transitive = true;
        }
        compile files('libs/InMobi-5.2.2.jar')
        compile files('libs/libadapterinmobi.jar')
        compile files('libs/StartAppAdMobMediation-1.0.1.jar')
        compile files('libs/StartAppInApp-3.3.1.jar')
        compile 'org.adw.library:discrete-seekbar:1.0.1'
        compile 'com.pnikosis:materialish-progress:1.0'
    }

Если я изменю сервисы воспроизведения на 9.0.0, все будет нормально. Что мне здесь не хватает?

50
tbag

Вам нужно поместить строку apply plugin: 'com.google.gms.google-services' под блоком dependencies - это позволит плагину определить, какую версию сервисов Play вы используете.

149
ianhanniballake

Если у вас есть зависимости Firebase. Обновите их версию в соответствии с версией сервисов Google: Пример:

 //Firebase Crashreports
 compile 'com.google.firebase:firebase-crash:9.6.1'
//Firebase Analytics
compile 'com.google.firebase:firebase-core:9.6.1'
compile 'com.google.Android.gms:play-services-analytics:9.6.1'
compile 'com.google.Android.gms:play-services-gcm:9.6.1'

Все должны иметь одинаковую версию 9.6.1

62
i_tanova

просто напишите это после зависимостей

apply plugin: 'com.google.gms.google-services'
3
Mor2

Я столкнулся с подобной проблемой. В верхней части, когда плагин был добавлен, он не работал для меня. Поэтому добавьте плагин в нижней части Gradle .. Это решит мою проблему конфликта Версия

 apply plugin: 'com.google.gms.google-services'

и добавить это зависимость этих строк

 compile 'com.google.firebase:firebase-core:9.2.0' 
 compile 'com.google.firebase:firebase-messaging:9.2.0'
compile 'com.google.Android.gms:play-services-location:9.2.0'
compile 'com.google.Android.gms:play-services-places:9.2.0'
1
justchill

У вас есть линия

apply plugin: 'com.google.gms.google-services' 

строка в конце файла build.gradle?

Эта ошибка возникала в основном, когда «применить плагин» ставится вверху.

1
Er. Joshi

Я сталкиваюсь с той же проблемой. 

Мое решение состояло не в том, чтобы добавить что-либо в код, а в загрузку Google Support Repository - вы можете найти его в Tools -> Android -> SDK Manager -> SDK Tools

1
mr0

Просто примените гугл-сервисы ниже зависимости .. у меня сработало.

1
Mwongera

Я установил Google Repository:

Android> SDK Manager . Обновите Android Studio SDK Manager: нажмите Инструменты SDK, разверните Репозиторий поддержки, выберите Google Repository и нажмите кнопку ОК.

0
Fabio Campinho