it-swarm.com.ru

Не удалось найти метод Android () для аргументов в проекте Android Studio

Я пытаюсь выполнить синхронизацию оценок в своем студийном проекте Android, и я продолжаю получать эту ошибку в заголовке. Мой файл build.gradle 

// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
repositories {
    jcenter()
}
dependencies {
    classpath 'com.Android.tools.build:gradle:2.2.1'

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}
}
allprojects {
repositories {
    jcenter()
}
}
task clean(type: Delete) {
delete rootProject.buildDir
}

Android {
compileSdkVersion 24
buildToolsVersion '24.0.0'
}
dependencies {

}

Мое сообщение об ошибке

Gradle sync failed: Could not find method Android() for arguments [[email protected]] on root project 'MyRadio

Я посмотрел в Интернете и попробовал несколько решений, но ничего не работает. Что это вообще значит? Любая помощь будет оценена.

10
Heyya

Вы используете неправильный файл build.gradle.

В вашем файле верхнего уровня вы не можете определить блок Android.

Просто переместите эту часть в файл module/build.Gradle.

Android {
compileSdkVersion 17
buildToolsVersion '23.0.0'
}
dependencies {
compile files('app/libs/junit-4.12-JavaDoc.jar')
}
apply plugin: 'maven'
16
Atman Bhatt

Переместите свою часть Android {} в этот файл  build.gradle

6
Ajith Pandian

 Edit this gradle file В настоящее время вы редактируете файл Gradle верхнего уровня, но вы должны редактировать уровень приложения

добавить зависимости там.

4
Rjz Satvara

Каждый модуль, который вы добавляете в файл has its own build.gradle проекта Android Studio. Любые зависимости, которые вы хотите добавить, добавляются в связанный файл build.gradle модуля . Таким образом, в вашем случае вы должны добавить свои зависимости в файл build.gradle вашего приложения.

Вот изображение, показывающее, где вы должны добавить это.

 Build Gradle

1
Vivek Mishra

Обновить Gradle после удаления ниже

Android {
compileSdkVersion 24
buildToolsVersion '24.0.0'
}
dependencies {

}

Меня устраивает

1
Umino San

Проверьте, отсутствует ли Build.Gradle вашего уровня APP Plugin

затем добавьте apply plugin: 'com.Android.application' 

на уровне приложения Build.Gradle

Из моего решения.

0
Nikunj Paradva