it-swarm.com.ru

Как установить плагин Android ADT в Eclipse?

Я следовал инструкциям на Плагин ADT для Eclipse но я получил это сообщение при установке в Eclipse:

Cannot complete the install because one or more required items could not be found
  Software being installed: Android Development Tools 0.9.9.v201009221407-60953 
      (com.Android.ide.Eclipse.adt.feature.group 0.9.9.v201009221407-60953)
  Missing requirement: Android Development Tools 0.9.9.v201009221407-60953
      (com.Android.ide.Eclipse.adt.feature.group 0.9.9.v201009221407-60953)
      requires 'org.Eclipse.gef 0.0.0' but it could not be found

Я пробовал как с 64-битной, так и с 32-битной Eclipse Galileo свежие установки. Я использую Windows 7.

Update: Я следовал инструкциям на org.Eclipse.gef 0.0.0, необходимом для установки Инструментов разработки Android на Eclipse 3.5.1 , и установил GEF SDK 3.5.2, но теперь я получил новое похожее сообщение об ошибке при установке ADT:

Cannot complete the install because one or more required items could not be found
  Software being installed: Android Development Tools 0.9.9.v201009221407-60953 
      (com.Android.ide.Eclipse.adt.feature.group 0.9.9.v201009221407-60953)
  Missing requirement: Android Development Tools 0.9.9.v201009221407-60953
      (com.Android.ide.Eclipse.adt.feature.group 0.9.9.v201009221407-60953)
      requires 'org.Eclipse.wst.sse.core 0.0.0' but it could not be found

Как я могу установить Android ADT Plugin для Eclipse 3.5.2 в Windows?

21
Jonas

Наконец, я следовал инструкциям на Во время установки возникает ошибка, связанная с требованием org.Eclipse.wst.sse.ui. Как мне это исправить? и установил Google Plugin для Eclipse Galileo , после чего установка Android ADT Plugin работала без проблем, наконец-то.

15
Jonas

На Ubuntu 11 устанавливается Eclipse 3.7 (Indigo). Чтобы это работало, мне пришлось добавить http://download.Eclipse.org/releases/Indigo в список источников. После этого он работал как шарм.

6
Robin Degen

В Windows 7 запустите Eclipse, используя от имени администратора .

PS: я сделал это в сочетании с другими советами, такими как добавление URL релиза Indigo в доступные источники и использование HTTP вместо HTTPS, и я не проверял, должны ли быть выполнены все три требования или достаточно первого из них.

5
Dmitry Tashkinov

Это сработало для меня

  1. Перейдите в Справка-> Установить новое программное обеспечение
  2. Перейти к «Доступные источники программного обеспечения»
  3. Проверьте все коробки
  4. Попробуйте официальные инструкции еще раз. http://developer.Android.com/sdk/Eclipse-adt.html#install
3
Dan

Устанавливая на 3.7 Indigo, я обнаружил, что плагин теперь называется: 

Серверные адаптеры WST

org.Eclipse.wst.server_adapters.feature.feature.group

2
TomDestry

Я получил такое же сообщение в Galileo, после чего установил Indigo, и это сработало, хотя я проверил только инструменты разработчика и плагины, остальные два я не установил, и с ними произошла ошибка. Но ADT работает сейчас. 

1
DrunkenDemon

Если кто-то обновляет Eclipse 3.6, и он скопировал (переписал или объединил) свои каталоги, вы получите конфликтующую ошибку зависимости, и ADT не установится . Убедитесь, что вы вернулись, удалите Eclipse, разархивируйте новый Eclipse свежим на новое место и запустить его! Работал для меня!

0
Harsh Alkutkar

Вы должны установить соединение вашего компьютера без прокси и запустить Eclipse от имени администратора

0
nbsrujan