it-swarm.com.ru

как изменить целевой уровень API моего приложения с 23 на 26

У меня проблема, когда я пытаюсь загрузить свое приложение в консоль Google Play, и это уровень API, который должен быть 26, а мое приложение только что разработано с 23 версией, и теперь я не знаю, как изменить эту версию API с 23 до 26, чтобы он работал без ошибок.

Помоги мне, пожалуйста!

2
Mahrez

вы можете изменить свой API из файла build.gradle.  enter image description here

5
Harish Rawal

Шаги:

  1. Перейдите в Файл> Структура проекта.
  2. выберите App Module в левой панели
  3. выберите вкладку Flavor из вкладок верхнего меню
  4. Вы можете изменить Min SDK версию (в вашем случае измените Target SDK Version на 26)
  5. Нажмите Ok

Ссылка: http://abhiandroid.com/androidstudio/change-api-sdk-level-Android-studio.html

3
Subrata

Тем не менее, есть ответ, который ответил друг ниже, просто хочу сообщить, что при изменении версии API. Вам также необходимо рассмотреть библиотеку из приложения build.gradle.

например:

 enter image description here

Если вы измените версию, файл библиотеки по умолчанию должен измениться на версию вашей версии API. 

Пример

implementation 'com.Android.support:appcompat-v7:27.1.0' с моей версией API 27

2
Kopi Bryant

Вы можете изменить minSdkVersion с 23 на 26, В разделе «Сценарии Gradle >> build.gradle (Module: app)». Затем выполнить синхронизацию.

0
M.J Jalali