it-swarm.com.ru

Gradle: более одного варианта проекта: myLib соответствует атрибутам потребителя

Библиотека, которую я написал myLib, использует RemoteMessage из Firebase, само приложение также использует Firebase.

Использование gradle 4.7. Также с этим сталкиваются в 4.4.1.

Как это исправить?

project.gradle

buildscript {

    repositories {
        google()
        jcenter()
        mavenCentral()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.1.2'
        classpath 'com.google.gms:google-services:3.3.0'
    }
}

allprojects {
    repositories {
        google()
        jcenter()
        mavenCentral()
        mavenLocal()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

app.gradle

apply plugin: 'com.Android.application'

Android {
    compileSdkVersion 27
    defaultConfig {
        applicationId "com.test.app"
        minSdkVersion 19
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"
        multiDexEnabled true
    }

    dexOptions {
        preDexLibraries = false
        jumboMode = false
        javaMaxHeapSize "2048M"
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
    productFlavors {
    }
}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])

    implementation 'com.Android.support:appcompat-v7:27.1.1'

    implementation 'com.google.Android.gms:play-services-gcm:12.0.1'
    implementation 'com.google.Android.gms:play-services:12.0.1'
    implementation 'com.google.firebase:firebase-core:12.0.1'
    implementation 'com.google.firebase:firebase-messaging:12.0.1'
    implementation 'com.google.firebase:firebase-crash:12.0.1'

    implementation project(":myLib")
}

apply plugin: 'com.google.gms.google-services'

myLib.gradle

apply plugin: 'com.Android.library'

Android {
    compileSdkVersion 27



    defaultConfig {
        minSdkVersion 19
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"

        testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"

    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }

}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])

    implementation 'com.Android.support:appcompat-v7:27.1.1'

    implementation group: 'com.google.code.gson', name: 'gson', version: '2.8.2'
    implementation 'com.j256.ormlite:ormlite-core:5.0'
    implementation 'com.j256.ormlite:ormlite-Android:5.0'

    implementation 'com.google.firebase:firebase-messaging:12.0.1'
}

Ошибка вывода из testApp\myLib> gradle clean assembleDebug и testApp\app> gradle clean assembleDebug

Более одного варианта проекта: myLib соответствует потребительские атрибуты:

  • Конфигурация ': myLib: debugApiElements' вариант Android-aidl:
    • Найден тип артефакта 'Android-aidl', но он не требуется.
    • Обязательное com.Android.build.api.attributes.BuildTypeAttr 'debug' и найдено совместимое значение 'debug'.
    • Найден com.Android.build.api.attributes.VariantAttr «debug», но не требуется.
    • Требуется com.Android.build.gradle.internal.dependency.AndroidTypeAttr 'Aar' и найдено совместимое значение 'Aar'.
    • Требуется org.gradle.usage 'Java-api' и найдено совместимое значение 'Java-api'.
  • Конфигурация ': myLib: debugApiElements' вариант Android-классов:
    • Найден тип ArtifactType для Android-классов, но он не требуется.
    • Обязательное com.Android.build.api.attributes.BuildTypeAttr 'debug' и найдено совместимое значение 'debug'.
    • Найден com.Android.build.api.attributes.VariantAttr «debug», но не требуется.
    • Требуется com.Android.build.gradle.internal.dependency.AndroidTypeAttr 'Aar' и найдено совместимое значение 'Aar'.
    • Требуется org.gradle.usage 'Java-api' и найдено совместимое значение 'Java-api'.
  • Конфигурация ': myLib: debugApiElements' вариант Android-манифеста:
    • Найден тип артефакта 'Android-манифест', но не требуется.
    • Обязательное com.Android.build.api.attributes.BuildTypeAttr 'debug' и найдено совместимое значение 'debug'.
    • Найден com.Android.build.api.attributes.VariantAttr «debug», но не требуется.
    • Требуется com.Android.build.gradle.internal.dependency.AndroidTypeAttr 'Aar' и найдено совместимое значение 'Aar'.
    • Требуется org.gradle.usage 'Java-api' и найдено совместимое значение 'Java-api'.
  • Конфигурация ': myLib: debugApiElements' вариант Android-визуализации:
    • Найден тип артефакта 'Android-renderscript', но он не требуется.
    • Обязательное com.Android.build.api.attributes.BuildTypeAttr 'debug' и найдено совместимое значение 'debug'.
    • Найден com.Android.build.api.attributes.VariantAttr «debug», но не требуется.
    • Требуется com.Android.build.gradle.internal.dependency.AndroidTypeAttr 'Aar' и найдено совместимое значение 'Aar'.
    • Требуется org.gradle.usage 'Java-api' и найдено совместимое значение 'Java-api'.
  • Конфигурация ': myLib: debugApiElements' вариант jar:
    • Найден артефактТип 'jar', но не требуется.
    • Обязательное com.Android.build.api.attributes.BuildTypeAttr 'debug' и найдено совместимое значение 'debug'.
    • Найден com.Android.build.api.attributes.VariantAttr «debug», но не требуется.
    • Требуется com.Android.build.gradle.internal.dependency.AndroidTypeAttr 'Aar' и найдено совместимое значение 'Aar'.
    • Требуется org.gradle.usage 'Java-api' и найдено совместимое значение 'Java-api'.
81
theAnonymous

Подключаемый модуль google-services предназначен для работы с сервисами Google Play и Firebase 15+, но вы используете его с версией 12.0.1.

Решение состоит в том, чтобы:

EDIT 1: существует известная проблема использования google-services3.3 в многомодульных приложениях . Это означает, что понижение с google-services до 3.2.1 может быть вашим единственным вариантом, пока не будет выпущена новая версия, исправляющая ошибку.

EDIT 2: вышеупомянутая ошибка была исправлена ​​в версии 4.0.1 плагина google-services! (и версия 4.0.2 также исправляет NPE, возникший в некоторых случаях)

Кстати, вы должны перейти на FCM.GCM перестанет работать в не слишком отдаленном будущем.

86
Louis CAD

Я получаю эту ошибку при использовании google-сервисов: 3.3.0. 

Понизьте до classpath 'com.google.gms:google-services:3.2.1' в вашем проекте .gradle.

Это должно решить проблему.

28
Henrique Monte

Столкнулся с аналогичной проблемой при обновлении до 3.3.1 

Исправлено путем понижения до 3.2.1

Мы можем использовать версию Firebase> = 15 с 3.2.1

7
dddd2011

Ниже шаги сработали для меня --- 

  1. Перейдите в файл Android/build.gradle. 
  2. Поиск метода jcentre()
  3. Сдвиньте все методы jcenter() снизу внутри своего блока. 
1
Akhilesh Sinha

Я столкнулся с подобной проблемой в последние несколько дней. 

implementation 'com.google.Android.gms:play-services-auth:15.0.0'
implementation 'com.google.firebase:firebase-messaging:15.0.0'

решение было либо понизить до 

implementation 'com.google.Android.gms:play-services-auth:12.0.1'
implementation 'com.google.firebase:firebase-messaging:12.0.1'

или оставьте Google Cloud Services и полностью обновитесь до FCM. 

Обратите внимание, что у них разные номера версий, вы можете посмотреть это здесь

0
Poorya