it-swarm.com.ru

com.google.Android.gms: база измерения play-services-запрашивается различными другими библиотеками

Я обновил до gradle 4.0.1 и начал получать следующую ошибку

Библиотека com.google.Android.gms: база измерения play-services-is запрашивается различными другими библиотеками на [[15.0.4,15.0.4]], но разрешает до 15.0.2. Отключите плагин и проверьте свои зависимости дерево, используя ./gradlew: app: зависимости.

Мой проект не использует эту зависимость, поэтому я искал ее по всему миру, и она только появляется внутри

строить/промежуточные/ворса кэш/maven.google/COM/Google/Android/GMS/группа-index.xml

как эта линия

<play-services-measurement-base versions="15.0.0,15.0.2"/>

Поэтому я попытался удалить папку сборки и очистить проект, но он восстанавливает его с теми же значениями:/следовательно, ошибка все еще остается

104
Ilja

Фактическая проблема обсуждается в примечании к выпуску от 23 мая https://developers.google.com/Android/guides/releases#may_23_2018

По сути, вам нужно повысить все библиотеки Play Services и Firebase до их последней версии (, которая может отличаться для каждой версии 15) . Вы можете использовать https://mvnrepository.com/ , чтобы найти последнюю версию для каждой библиотеки.

Смотрите также: https://firebase.google.com/support/release-notes/Android#20180523

118
Nico

единственное рабочее решение для меня:

положить его на дно build.gradle 

com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true
65
htw

Убедитесь, что ваши сервисы Google play и Firebase зависимы от последней версии.

Также проверьте все ваши файлы Gradle, уровень модуля и уровень проекта, должна быть только одна общая версия зависимости для всех модулей. Может быть решена путем сохранения этих версий в переменной gradle уровня проекта.

Проверьте версию обновления служб Google Play

Последние версии сервисов Google Play

Проверьте наличие обновленной версии Firebase

Firebase Последний

Проверьте наличие обновленной версии Firebase для Android

Firebase Android Последний

21
abitcode

Я обновил 

    implementation 'com.google.Android.gms:play-services-analytics:16.0.3'

и это работает для меня

8
Amine M'hamed

изменение моего build.gradle на следующее работало для меня:

ext {
  googlePlayServicesVersion   = "15.0.1"
}

allprojects {
  repositories {
      mavenLocal()
      maven { url 'http://maven.google.com' }
      jcenter { url "http://jcenter.bintray.com/" }
      google()
      maven {
        // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
        url "$rootDir/../node_modules/react-native/Android"
      }

      configurations.all {
        resolutionStrategy {
            force "com.google.Android.gms:play-services-basement:$googlePlayServicesVersion"
            force "com.google.Android.gms:play-services-tasks:$googlePlayServicesVersion"
        }
      }
  }
}
6
mk7danny

В моем случае использование последних версий dependencies решило мою проблему:

'com.google.Android.gms:play-services-analytics:16.0.1'
'com.google.Android.gms:play-services-tagmanager:16.0.1'
5
Murat

Добавить в список ваших зависимостей. Теперь нужно иметь его для правильной работы всех зависимостей firebase:

implementation 'com.google.firebase:firebase-core:16.0.1'
3
PavelGP

Это может произойти, если ваш плагин Android Gradle очень старый, даже если вы используете только одну библиотеку Google! Видимо все библиотеки Google раньше должны были быть точно такой же версии. Теперь они не должны быть такими же, только последние. Когда указывается даже одна библиотека, она вытягивает зависимости, где версии не совпадают, а старый плагин Android Gradle рвет.

Установите более новую версию, например:

buildscript {
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.3.2'
    }
}

Вам может потребоваться обновить Gradle, чтобы использовать более новый плагин (он сообщит вам).

3
NateS

Для меня эта ошибка появилась после интеграции Crashlytics через Firebase, из-за конфликта версий между 

implementation 'com.google.firebase:firebase-core:16.0.4'
implementation 'com.google.Android.gms:play-services-location:15.0.1'

Сначала я попробовал понизить Firebase Core до 15.0.1, но кажется такой версии нет, только 15.0.0 и 15.0.2! Вместо этого мне пришлось понизить обе версии до 15.0.0, поэтому я в конечном итоге 

implementation 'com.google.firebase:firebase-core:15.0.0'
implementation 'com.google.Android.gms:play-services-location:15.0.0'

Так что теперь это работает, но я получаю эти раздражающие предупреждения Lint о доступности новых версий. Этот разгром версий - чертовски беспорядок.

2
Magnus W

Единственное решение, которое работает для меня (найдено где-то в SOF) (нет ссылки):

в топе основной build.grale 

allprojects {

subprojects {
    project.configurations.all {
        resolutionStrategy.eachDependency { details ->
            if (details.requested.group == 'com.google.Android.gms'
                    && !details.requested.name.contains('multidex')) {
                details.useVersion "x.y.z"
            }
        }
    }
}
2
issamux

Подобная проблема возникла у меня, когда я попытался добавить базу данных Firebase в свой проект.

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-database:16.0.3'

Эта проблема может быть решена путем понижения или обновления обеих версий до аналогичного уровня . Поэтому я понизил базу данных Firebase до

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-database:16.0.1'

и это сработало! Все доступные версии можно искать на этом сайте: https://mvnrepository.com/

2
Harshit Agarwall

Я заметил, что в журналах отладки упоминается старая версия firebase-analytics (16.0.0). Явное добавление последней версии решило проблему:

implementation "com.google.firebase:firebase-analytics:16.0.3"
1
smok

У меня была такая же проблема 

Просто убедитесь, что у вас есть последние версии всех зависимостей. Я использовал текущие версии для ядра Firebase и auth . В более новых версиях исправлены ошибки. 

Вы можете получить последние версии здесь: https://firebase.google.com/support/release-notes/Android

Использование последней версии на текущий момент времени:

в app/build.gradle:

dependencies {
implementation 'com.google.firebase:firebase-core:16.0.6'
implementation 'com.google.firebase:firebase-auth:16.1.0'
}
1
shellym

Я предполагаю, что следующая ошибка вызвана из-за различных версий зависимостей firebase. Для меня изменение версии всех зависимостей, которые я реализую в моем проекте, до 16.0.1, работало как прелесть.

Для меня ошибка была создана строкой: com.google.firebase:firebase-auth:16.0.2

И я изменил его на: com.google.firebase:firebase-auth:16.0.1

И это сработало. Надеюсь, это поможет.

1
Vipin George

Обновите все ваши зависимости до последней версии, и это решит проблему.

Не нужно добавлять 
com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true

Это приведет к сбоям, если вы используете смешанные версии.

1
RakeshGupta

1. Откройте уровень проекта build.gradle

Обновите com.google.gms:google-services версию до последней. Отслеживать последний выпуск . На момент ответа последний является 4.1.0

2. Откройте уровень приложения build.gradle

Обновите ниже зависимости, если вы используете любой. Обратите внимание, что у firebase есть отдельные версии для каждой зависимости.

Использовать последние библиотеки Firebase . На момент ответа последние версии находятся ниже.

Firebase Core                com.google.firebase:firebase-core:16.0.3
Ads                          com.google.firebase:firebase-ads:15.0.1
Analytics                    com.google.firebase:firebase-analytics:16.0.3
App Indexing                 com.google.firebase:firebase-appindexing:16.0.1
Authentication               com.google.firebase:firebase-auth:16.0.3
Cloud Firestore              com.google.firebase:firebase-firestore:17.1.0
Cloud Functions              com.google.firebase:firebase-functions:16.1.0
Cloud Messaging              com.google.firebase:firebase-messaging:17.3.2
Cloud Storage   c            om.google.firebase:firebase-storage:16.0.2
Crash Reporting              com.google.firebase:firebase-crash:16.2.0
Crashlytics                  com.crashlytics.sdk.Android:crashlytics:2.9.5
Dynamic Links                com.google.firebase:firebase-dynamic-links:16.1.1
Invites                      com.google.firebase:firebase-invites:16.0.3
In-App Messaging             com.google.firebase:firebase-inappmessaging:17.0.1
In-App Messaging Display     com.google.firebase:firebase-inappmessaging-display:17.0.1
ML Kit: Model Interpreter    com.google.firebase:firebase-ml-model-interpreter:16.2.0
ML Kit: Vision               com.google.firebase:firebase-ml-vision:17.0.0
ML Kit: Image Labeling       com.google.firebase:firebase-ml-vision-image-label-model:15.0.0
Performance Monitoring       com.google.firebase:firebase-perf:16.1.0
Realtime Database            com.google.firebase:firebase-database:16.0.2
Remote Config                com.google.firebase:firebase-config:16.0.0

Синхронизация и сборка ...

1
Khemraj

замените "+" на номер версии, он выберет последнюю версию . вот так:

implementation 'com.google.firebase:firebase-analytics:+'

0
Kyi Moe Min

firebase-core & firebase-database ... должна быть той же версии:

реализация 'com.google.firebase: ядро ​​firebase: 16.0.1' реализация 'com.google.firebase: база данных firebase: 16.0.1'

0
RD QUOCVIET

Я получал похожую ошибку, когда пытался использовать одну и ту же версию для всего:

implementation 'com.google.Android.gms:play-services-base:16.0.0'
implementation 'com.google.Android.gms:play-services-analytics:16.0.0'
implementation 'com.google.Android.gms:play-services-awareness:16.0.0'
implementation 'com.google.Android.gms:play-services-cast:16.0.0'
implementation 'com.google.Android.gms:play-services-gcm:16.0.0'
implementation 'com.google.Android.gms:play-services-location:16.0.0'
implementation 'com.google.firebase:firebase-messaging:16.0.0'

Проблема была исправлена ​​для меня, когда я сделал следующее:

1) Использована последняя доступная версия каждого сервиса:

implementation 'com.google.Android.gms:play-services-base:16.1.0'
implementation 'com.google.Android.gms:play-services-analytics:16.0.8'
implementation 'com.google.Android.gms:play-services-awareness:16.0.0'
implementation 'com.google.Android.gms:play-services-cast:16.2.0'
implementation 'com.google.Android.gms:play-services-gcm:16.1.0'
implementation 'com.google.Android.gms:play-services-location:16.0.0'
implementation 'com.google.firebase:firebase-messaging:17.6.0'

2) Обновлена ​​Android Studio до последней версии, доступной сегодня (Android Studio 3.4).

3) Обновлена ​​версия плагина Android Gradle до 3.4.0 и версия Gradle до 5.1.1.

0
Jaime Montoya

Вы можете найти библиотеку, извлекающую эту зависимость, используя:

$ ./gradlew app:dependencies
0
Nico

У меня есть похожая проблема, которая решена с помощью:

  1. На уровне приложения: обновите все зависимости Firebase до последней версии самая последняя
  2. На уровне проекта gradle: обновите зависимость до последней: gms.google-services, в моем случае это было: 'com.google.gms: google-services: 4.2.0'
0
tabebqena

Была такая же проблема. Вы должны удалить двоеточие: после версии в Gradle (это ошибка).

Эти настройки работали для меня:

implementation 'com.google.firebase:firebase-firestore:17.1.5'

Также установите для multiDexEnabled значение true в градле (если вы получили ошибку DexOverflowException):

    Android {
        compileSdkVersion 27
..
            multiDexEnabled true
        }
0
live-love

Это может быть решено с помощью последнего набора зависимостей.

Вы можете найти последние на сайте ниже

https://firebase.google.com/support/release-notes/Android#20180523

Опубликуйте эту синхронизацию снова и она должна работать нормально

0
Anshu Kumar Gupta

У меня была та же проблема, когда я пытался добавить реализацию базы данных firebase, если я прокомментировал эту строку, она работает, поэтому после нескольких попыток я перешел на https://firebase.google.com/docs/Android/setup

Там я проверил версии доступных библиотек, и мое ядро ​​firebase было на 16.0.1 (текущая версия 16.0.4), поэтому я вручную изменил его, и он работал просто отлично, сборка и синхронизация прошли успешно.

0
Anibal

У меня та же проблема, затем я решил выполнить случайную реализацию 'com.google.firebase: firebase-auth: 15+' вместо реализации 'com.google.firebase: firebase-auth: 16.1.0'

0
altintasomer

В моем случае я использую последний rnfirebase ниже URL

https://rnfirebase.io/docs/v4.3.x/installation/Android

добавить ниже в Android/app/proguard-rules.pro)

-keep class io.invertase.firebase.** { *; }
-dontwarn io.invertase.firebase.**
0
krish

вот простое решение. проблема в том, что вы используете последнюю версию для одной библиотеки и более низкую версию для другой библиотеки. попытаться сбалансировать это. Лучшее решение - использовать последнюю версию для всех ваших библиотек. Чтобы решить вашу проблему, просто нажмите здесь и посмотрите последнюю версию библиотек, включите ее в свой проект и затем синхронизируйте.
в моем случае у меня работает следующее:

dependencies{
    implementation 'com.google.firebase:firebase-core:16.0.7'
    implementation 'com.google.firebase:firebase-database:16.1.0'
}
apply plugin: 'com.google.gms.google-services'
0
Abdulhakim Zeinu
In my case

ERROR: The library com.google.Android.gms:play-services-basement is being requested by various other libraries at [[15.0.1,15.0.1]], but resolves to 16.0.1. Disable the plugin and check your dependencies tree using ./gradlew :app:dependencies.

It solves my issue
implementation 'com.google.Android.gms:play-services-analytics:16.0.1'
0
Kishore Reddy

В моем случае я просто удаляю 

implementation "com.google.Android.gms:play-services-ads:16.0.0

и добавьте зависимости объявлений Firebase 

implementation 'com.google.firebase:firebase-ads:17.1.2'
0
code4rox

В моем случае я заменил мой файл build.gradle на эту строку

implementation 'com.google.firebase:firebase-core:16.0.8'

с

implementation 'com.google.firebase:firebase-core:15.0.0' 

и добавил эту строку

implementation 'com.google.Android.gms:play-services-location:15.0.0'

Теперь это хорошо

0
Maddu Swaroop

просто поместите ниже код:

    implementation 'com.google.firebase:firebase-core:16.0.6'
    implementation 'com.google.firebase:firebase-database:16.0.6'

и восстановить. это работает просто хорошо для меня

0
shahid

Я столкнулся с этой проблемой и заметил, что в заметках release упоминается:

Firebase теперь требует, чтобы в файле gradle приложения явно указывалось com.google.firebase: firebase-core как зависимость для служб Firebase, чтобы они работали должным образом.

Создание firebase-core зависимости приложения (а также зависимости библиотеки) решило эту проблему для меня.

0
Tad

У меня была ошибка The library com.google.Android.gms:play-services-measurement-base is being requested by various other libraries at [[16.0.2,16.0.2]], but resolves to 16.0.0. Disable the plugin and check your dependencies tree using ./gradlew :app:dependencies.

Запуск ./gradlew :app:dependencies покажет, какие зависимости требуют неправильных (те, что в квадратной скобке). Для меня проблема исходила от firebase-core: 16.0.3, как показано ниже. Я исправил это путем понижения firebase-core до 16.0.1

+--- com.google.firebase:firebase-core:16.0.3
|    +--- com.google.firebase:firebase-analytics:16.0.3
|    |    +--- com.google.Android.gms:play-services-basement:15.0.1
|    |    |    \--- com.Android.support:support-v4:26.1.0 (*)
|    |    +--- com.google.Android.gms:play-services-measurement-api:[16.0.1] -> 16.0.1
|    |    |    +--- com.google.Android.gms:play-services-ads-identifier:15.0.1
|    |    |    |    \--- com.google.Android.gms:play-services-basement:[15.0.1,16.0.0) -> 15.0.1 (*)
|    |    |    +--- com.google.Android.gms:play-services-basement:15.0.1 (*)
|    |    |    +--- com.google.Android.gms:play-services-measurement-base:[16.0.2] -> 16.0.2
0
Eric Kim

Если сообщение:

Библиотека com.google.Android.gms: база измерения play-services-is запрашивается различными другими библиотеками на [[15.0.4,15.0.4]], но разрешается в 15.0.2. Отключите плагин и проверьте свои зависимости дерево, используя ./gradlew: app: зависимости.

Измените версию всех библиотек сервисов воспроизведения, которые вы используете, на ту, которая вам нужна (в данном случае 15.0.2 ), может решить проблему. 

В моем случае я изменился:

implementation 'com.google.Android.gms:play-services-base:+' -> implementation 'com.google.Android.gms:play-services-base:15.0.2'
implementation 'com.google.Android.gms:play-services-location:+' -> implementation 'com.google.Android.gms:play-services-location:15.0.2'
implementation 'com.google.Android.gms:play-services-maps:+' -> implementation 'com.google.Android.gms:play-services-maps:15.0.2'
implementation 'com.google.Android.gms:play-services-auth:+' -> implementation 'com.google.Android.gms:play-services-auth:15.0.2'
implementation 'com.google.Android.gms:play-services-places:+' -> implementation 'com.google.Android.gms:play-services-places:15.0.2'
0
Jose Q

Решено здесь: Я тоже столкнулся с той же проблемой, когда пытался добавить аварийный анализ в firebase. Обновите последнюю версию зависимостей для com.google.Android.gms: play-services и com.google.firebase: ...... . Это автоматически решит проблемы

0
Priya Rajan

Я изменил следующие зависимости в моем проекте, чтобы он работал.

build.gradle (приложение):

implementation 'com.google.firebase:firebase-core:16.0.1'

в

implementation 'com.google.firebase:firebase-core:16.0.8'

build.gradle (приложение):

classpath 'com.google.gms:google-services:4.0.1'

в

classpath 'com.google.gms:google-services:4.2.0'

**** Примечание:

Используйте следующую ссылку для обновленного использования библиотек, которые имеют зависимости https://firebase.google.com/docs/Android/setup

0
Ali Baba