it-swarm.com.ru

Android SDK Ошибка при загрузке SDK:

enter image description here

Как мне решить эту проблему?

43
amine life

Удаление (удаление) пакета Android Wear ARM Образ системы EABI v7a, доступный в Android 5.1.1 (API 22), решает эту проблему. 

Подробности смотрите по этой ссылке - Ошибка загрузки SDK при запуске Eclipse

54
Amrit Pal Singh

У меня было то же сообщение об ошибке, но одним из предложенных решений было определение моего приложения для работы с API level 19. На самом деле это не было вариантом для меня, поэтому мое решение было удаление пакетов из API 22:

  • Android Wear ARM Образ системы EABI v7a
  • Android Wear Изображение системы Intel x86 Atom

enter image description here

34
Elenasys

У меня просто была такая же проблема при попытке установить Android SDK для libgdx. Я решил эту проблему, удалив каждый пакет из «Android 5.1.1 (API 22)» в Android SDK Manager, за исключением документации для Android SDK, платформы SDK, примеров для SDK, ARM образа системы EABI v7a, API Google и источники для Android SDK.

enter image description here

Это решило ошибку для меня. Я думаю, это была проблема с другими пакетами. Надеюсь, это поможет :)

/EDIT: Это, к сожалению, также искажает libgdx, не распознавая мою версию API22. Не совсем уверен, почему именно, так как он успешно отображается в настройках Android в Eclipse. : / Так что, если у кого-то есть исправление, мне было бы интересно, а также ^^

4
The_Blog

Я избавился от ошибки, закомментировав элемент all <d:skin /> в двух файлах:

  • C:\Users\"Имя пользователя"\AppData\Local\Android\Android-SDK\система-изображения\Android-22\Android износом\x86\devices.xml
  • C:\Users\"Имя пользователя"\AppData\Local\Android\Android-SDK\система-изображения\Android-22\Android износом\armeabi-v7a\devices.xml

как это

<!--<d:skin>AndroidWearSquare</d:skin>-->
4
Puliyo

Для меня решение было удалить Android Wear Intel x86 System ImageAndroid 5.1.1 (API 22)).

Но мой эмулятор все равно не запустится! Принесите на Android Studio ...

0
ban-geoengineering

Я мог избавиться от ошибки, удалив оба изнашиваемых образа из пакета API 22 в SDK Manager.

0
Prabhakar

Похоже, что все последние эмуляторы Android Wear и TV имеют эту проблему. Только удаление всех из них решило эту проблему для меня. Просто пройдите их все в SDK-менеджере и удалите их все - должно помочь. В случае, если вам нужны эмуляторы Wear и TV - похоже, сейчас нет другого пути, кроме как использовать Android Studio для разработки. Такова жизнь.

0
Serj.by